subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
594 views 3 comments
by anonymous

Hello, I would like to ask something regarding the Teltonika 955 router:

with the latest firmware RUT9XX_R_00.06.07.5 (but also of the others, I have to complete some tests) often the PPP (or QMI) authentications to authenticate the SIM on our radius server fail.
The teltonika no longer sends the credentials saved in the Network -> Mobile page but sends empty credentials, as you can see in the table below.  If I restart the router often the problem is solved.

I realized that I can replicate the problem by scanning the operators. If I go to Network -> Mobile -> Network Operators and click on Scan for Operators, teltonika is no longer able to reconnect to the network, either if I select the right operator or if I leave it automatically.

If I look at the logs when it fails to authenticate I see these two strange things compared to when it connects:

- No auth is possible

- Modem hangup


If I restart the modem from Status -> Network the problem is not solved. I only solve it with a restart of the router.


1 Answer

0 votes
by anonymous

Did you use custom APN for your device?

Is it a common issue? Or only one device is presenting this behavior?

Did you try restoring to default settings to avoid any FW corrupt file?

by anonymous

I think I have discovered some interesting things: the problem I have appears only from firmware RUT9XX_R_00.06.06.1 upwards.

In these firmware, if I reset the router and only configure the APN as in the picture:
immediately connects. But if I do any other operation that reloads the SIM settings it does not connect to the data network.
I compared the file configurations:
\ etc \ config \ simcard
\ etc \ config \ network

with the latest working firmware RUT9XX_R_00.06.05.3 and the non-working one RUT9XX_R_00.06.06.1.



As you can see, in the non-working configuration of the right image, the Teltonika sets up the PPP interface and the SIM without authentication (PAP). In fact, in their place, "none" appears.

If I export the conf, change the parameters and reload it the Teltonika works. However, if I update the firmware or change any parameter of the SIM I lose the correction. This must definitely be a bug, perhaps when setting up a manual APN.

by anonymous

Sorry for the delay, I'll perform some tests and let you know results as soon as possible.

Which operator are you using for?

by anonymous


I tried to reproduce the issue and I couldn't do it. Everytime I changed from QMI to PPP or vice-versa, or from CHAP to PAP, PAP to CHAP the result is the same.

option auth_mode 'chap' or option auth_mode 'pap' for each case.

Even connecting to the network without any trouble.

Is it a common issue? Or only one device is presenting this behavior?
Did you try restoring the device via Bootloader?