subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
511 views 10 comments
by anonymous


Upgraded firmware, default to manufacturer defaults, power cycle modem.  Restore config from another RUT950 (both are M02 & Fw 06.07.5).  Create user default, green banner saying created but the created time/date does not update.  Also the Dynamic DNS does not update.  This issue first noted with firmware upgrade to 6.7.5

Found the only way to recover was to reset to manufacturers defaults, power cycle modem then manually set up every setting.  Backup config and then tried to re-install the backup config and it has the same issues with not creating a user default config and Dynamic DNS not updating.

Reset modem to manufacturers defaults, power cycle modem and manually enter every setting.  The Dynamic DNS and Create user defaults all work fine.

There is something wrong in the firmware RUT9XX_R_00.06.07.5. which causes these issues.  

Would greatly appreciate some assistance as I have five RUT950 M02 modems to setup and if the restore config worked all I need to do is to change the Dynamic DNS hostname and passwords.  To enter every firewall settings, etc it does take hours per modem.

by anonymous
I tried again to create a user default and it failed.  Also the Dynamic DNS still says NA on the status.

Please advise email and I can send you screen dumps and debug file.
by anonymous

Upgraded FW ver.: RUT9XX_R_00.06.07.7

I found each time I clicked on create user default, make a small change and save it, then click on create user default the backup file doubles in size.  I did this four times and the config file is now 3.2MBits.

With the new firmware when I click on remove user default the backup file goes down to 478kBits.

Default to manufacturer defaults and enter all the setups and create a backup and the file size is 239kBits.

Once you reach a file size of over 3MBits you are unable to create or delete the user defaults and this is where the Dynamic DNS does not work.  I purchased a new modem and sent this to the affected site.  I think I will need to deafault the faulty modem to manufacturers defaults (power cycle modem), upgrade the firmware (power cycle the modem) and restore the config,  This process worked on the new modem.

It seems there is an issue with creating a user default as it does not remove any existing defaults and each time you click on create user default the file size doubles till the modem possibly runs out of resources.  Then it wont recover.  Perhaps this may need a new firmware release to rectify.

1 Answer

0 votes
by anonymous

I have just tried to configure some services on my own RUT950 device, reset it while using the latest firmware and upload the backup. So far everything worked fine and all configured services uploaded correctly. Have you tried this process just on a single device or on multiple? I would suggest downloading a backup from already configured device on which you have noticed this issue and try to upload it to another device. Also, if the issue reproduces itself, provide information on certain features that fail to upload using backup. I will try to test more and if I will be able to reproduce, I will inform the RND department about this.

by anonymous

After firmware upgrade, default to manufacturer defaults, after power cycle load a backup config (from another RUT950 FW ver.: RUT9XX_R_00.06.07.5)

System > Administration > Backup

User default config and click on create.  You will see a green bar saying successful but the dat/time does not appear.

Services > Dynamic DNS

Status remains on NA

I have the RUT950-M02 builds.  This is repeatable after upgrading to FW ver.: RUT9XX_R_00.06.07.5

by anonymous


I have tested and unfortunately could not reproduce. User default configuration created and time appeared:

After restoring to user configuration testing DDNS interface status updated:

Could you try to restore your device to the factory default configuration and try to repeat your steps. If it still does not work, please send me a Troubleshoot file via private message to investigate further.


by anonymous
PM sent with attachment
by anonymous
Thank you very much, I will investigate your logs.
by anonymous
Any joy?   It would be great if there was a way to fix this remotely as the RUT950 is about 1000kms each way.
by anonymous

RUT950 FW ver.: RUT9XX_R_00.06.07.5.  Its the java script "upload-validation.js" and the check file size function returns false so it will never upload.


Serial 1107576961

Batch 0106

I have three with the same batch all with this same issue.  Also the user default and Dynamic DNS wont update.

by anonymous

Could you install the latest firmware version RUT9XX_R_00.06.07 via bootloader menu to one of your routers, afterwards please configure everything on that router by hand (make sure everything does work correctly) and create a new backup file. I do suspect that the issue lies within your backup file. No matter how many times I have tried to reproduce your issue, my DDNS service managed to reconnect itself after being uploaded.
by anonymous
The size of the backup file seems to grow each time you click on the save user default tab.  As I have been manually entering my settings after a few I click on the save user default.  Will give this a try and not save the user default until after it is finished and see how that goes.

On the RUT950 at the remote site am I able to manually delete the backup 'user default' files?  I am thinking if I can free the memory of the archived user defaults (now over 3meg and I cant upload on this forum due to file size) this may fix the issue but not sure if this is safe nor which files to delete.  Please advise.