subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
641 views 3 comments
by anonymous


the last couple days I ran into network issues on a RUT240. It uses the latest available FW (00.01.14) and every a few minutes it drops the mobile connection. By checking the logs (PPPD), I could only find that it is disconnected and a few minutes later reconnects to a 4G network (not really why). Some times had to reboot the router to restore the connection or deactivate and reactivate the SIM card (through the jasper platform, which seemed and the faster way to restore connection). 

I have come across with the Ping Reboot --> Restart mobile connection (PING) but the minimum interval between the PINGs is 5 mins (which is a bit too long in my case). 

I frequently check the connection status from the device that is plugged into the RUT240, so I was thinking to use JSON-RPC to restart mobile connection (Reregister JSON-RPC). My questions are (although the reason of why this may be happening is vague)
i)   what is the difference between reregistering and restarting mobile connection and which one seems to be the right one in my case?
ii)  what would the reason(s) be for dropping the connection?
iii) is there a link with all the commands and their format for the JSON-RPC (not only the JSON-RPC cmd)?
iv) what would the JSON-RPC be for restarting mobile connection?
v) what would the right place be to look at for information about the issues?

Note that the links include posts from this forum. Also, we are operating multiple devices in that area (mix of RUT240 and RUT950) and this is the only one with so many network issues (RSSI, RSRP, SINR, and RSRQ values are acceptable and many times it happens when these are quite good).

**** Logs (network type) showing the frequent disconnections  ****
344|2021-04-27 20:36:59|Mobile Data|Mobile data disconnected
345|2021-04-27 20:37:01|Network Type|Joined 4G LTE
346|2021-04-27 20:37:55|Mobile Data|Mobile data connected, IP: 10.99.x.x <operator>
347|2021-04-27 20:43:42|Mobile Data|Mobile data disconnected
348|2021-04-27 20:43:46|Network Type|Joined 4G LTE
349|2021-04-27 20:52:24|Mobile Data|Mobile data connected, IP: 10.99.x.x <operator>
350|2021-04-27 21:54:06|Mobile Data|Mobile data disconnected
351|2021-04-27 21:54:08|Network Type|Joined 4G LTE
352|2021-04-27 21:59:50|Network Operator|Connected to <operator> operator
353|2021-04-27 21:59:57|Mobile Data|Mobile data connected: <operator> 
354|2021-04-27 22:04:48|Mobile Data|Mobile data disconnected
355|2021-04-27 22:04:50|Network Type|Joined 4G LTE
356|2021-04-27 22:06:40|Mobile Data|Mobile data connected, IP: 10.220.x.x <operator>
357|2021-04-27 22:33:27|Mobile Data|Mobile data disconnected
358|2021-04-27 22:33:31|Network Type|Joined 4G LTE
359|2021-04-27 22:36:27|Network Operator|Connected to <operator> operator
360|2021-04-27 22:36:35|Mobile Data|Mobile data connected, IP: 10.242.x.x <operator>

Many thanks and regards,

1 Answer

0 votes
by anonymous


Thank you for contacting .

Restart Mobile connection will restart all the services in Mobile.

Reregister will only try to reregister with APN again.

There could be multiple reasons for mobile connection drop.

Use both the mobile antennas provided in the Box.

check if mobile antennas are properly connected and are not loose. 

Check if service mode is on auto in mobile settings.

What is signal strength you are receiving ?

Have you tried comparing with these ?

For the modem restart you can use following :

Command for json:

{"jsonrpc": "2.0", "id": 1, "method": "call", "params": [ "00000000000000000000000000", "file", "exec", { "command": "gsmctl", "params":["-D"] } ] }"

For the mobile connection drop you can share a troubleshoot file in DM . Click on my name and you will see option to send messages .

Troubleshoot file could be downloaded in System>Administration>Troubleshoot

Make sure device is on for 10-15 minutes before you download the troubleshoot file.




by anonymous


Since you brought that up, do you have any datasheet about the antennas characteristics? 

- The service mode is on auto in mobile settings.

- RSSI varies from -82 dBm to -70 dBm, whilst the RSRP between -93 dBm to -86 dBm. They are not great but still they do not justify the frequent disconnections IMHO. I have observed that even with RSSI as low as -98, -100 dBm and RSRP below -110 dBm, the router was connected to the internet (the values are in the lower bands of the tables as seen in Mobile Signal Strength)

By the way when I run the following to reregister:

payload = {
        "method": "call",
        "params": [session_id, "file", "exec",
        "jsonrpc": "2.0",
        "id": 1,
    response =, json=payload).json() 

The response is {u'jsonrpc': u'2.0', u'id': 1, u'result': [7]}  and when I log on the Web GUI it is not listed under the network events (as it does when I click on reregister via the Web GUI (under the Network). Is the command wrong? 


by anonymous

Edit v1.0

After some digging I noticed that the reregister() is not triggered (/sbin/ because the check_type is LTE (with the above JSON-RPC command. However, that does not seem to be the case when the reregister button is clicked on the Web GUI (directly call the reregister() instead?). I would expect to directly calling the reregister() or to have a flag skipping the INTERVAL that should be applied only when the Reregister box is ticked. 

Also, it would be nice to have a few lines describing the functionality of the bash scripts (there is a line in lithuanian I believe :) ). Is there a command to directly call the reregister() as when clicked on the WebGui? 

by anonymous


For Antenna:

Regarding signals you are right these are acceptable but to see the more clearer picture i would need troubleshoot file for diagnosis .

Troubleshoot file could be downloaded in System>Administration>Troubleshoot

In the command , can you try replacing restart with only start , if it works?
Also did you tried the command ?

{"jsonrpc": "2.0", "id": 1, "method": "call", "params": [ "00000000000000000000000000", "file", "exec", { "command": "gsmctl", "params":["-D"] } ] }"