subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
272 views 0 comments
by anonymous
Dear all,

I have a RUT850 unit, with latest firmware available. Have enabled Hotspot functionality with Cloud4Wi profile and works as expected.

I would like to have a separate wi-fi network from the same unit that is password protected and doesn't need other authentication for some IOT devices that doesn't support captive portals.

After enabling Hotspot, I created a new wireless network. It works, and has a separate DHCP server (192.168.1.x) from hotspot (192.168.2.x) that gives an address to the clients that are connecting to it. However the Internet is unreachable.

A similar question was posted some time ago here, but no conclusive answer was provided.

How can I allow WAN access to this secondary Wi-Fi network?

Thank you,


Update: as a workaround, I tried assigning a MAC ID rule (allow everyone except a bogus MAC ID) and activate hotspot on the secondary wi-fi network with "MAC ID auth". Internet would be accessible then but only after clicking the "Login" button on the landing page; this won't work with IOT devices.

2 Answers

0 votes
by anonymous
The firmware appears to have two bugs:

1. If I create two wireless networks, then I go to the Hotspot page and click Edit on the second network, then I select a profile (i.e. Cloud4Wi), the second network disappears from the Hotspot page and it is no longer accessible; requires factory reset to restore it.

2. If I enable Hotspot on a wireless network, then I add another wireless network without hotspot functionality, this result in the issue described above: DHCP works but no Internet connectivity

If I follow this order, it seems to work:

a. Configure first wireless network without encryption

b. Create second wireless network with encryption

c. Enable hotspot on first wireless network

With this sequence we obtain the desired result, hotspot on a wireless network and concurrently unrestricted Internet connectivity by connecting to the second network with its password.

There is a third bug in this case: QoS appear not working when connected to the hotspot, despite this is an officially supported device by Cloud4Wi and QoS is set in Cloud4Wi interface.
0 votes
by anonymous

Did you try using Zone forwarding or static routes?

Please take a look to these links and if you have more doubts please let me know.