subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
1,180 views 3 comments
I have a setup with a PLC connected to the RUT955 via RS485, and my setup in the Teltonika is Modbusgateway.

At first when I´m plugged in directly in the Teltonika with my computer via Ethernet cable I can read modbusadresses with out any problem.

But when I unplugg my computer from the Tektonika and then plug it in again after a while I can't read any modbusadresses any longer,

Do any one know why that is?

1 Answer

0 votes
by anonymous

Which firmware version your router uses?

However, I tested this and after disconnecting the cable from PC and connecting it back, I got several error's from Modbus tcp client that "No response received", but after retry connection, everything worked as expected. So the issue looks related with TCP connection establishment between router and PC since it takes time, which might be longer that ModBus TCP delay time.
Best answer
I have firmwareversion RUT9XX_R_00.03.832

When I try to reconnect it still does not work. I have also tried with different computers. If i restart the Teltonika it starts to work again.
by anonymous
At first try to upgrade router firmware with the latest version RUT9XX_R_00.05.04. When upgrading do not keep old settings.

Firmware download link:
The Firmware upgrade fixed it! Thanks for the help!