subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
830 views 3 comments
by anonymous
I have an RUT955 RUT9XX_R_00.06.08.2 and am trying to configure it to connect to a custom APN. I have put the SIM in my Google Pixel 2 and a Samsung S9 and configured the APN and it connects fine and gets the IP address I'm expecting, but when the same SIM is in the RUT955 the data connection state stays "Disconnected", and the operator state stays "Unregistered". I have good signal strength so it should connect. The APN I'm using is a custom one provided by the mobile provider I'm working with for a private network connection. I've tried QMI and PPP, putting quotes around the APN name, rebooting, resetting, older firmware versions, and it just won't connect.

Are there any additional troubleshooting logs or tools I could access over SSH to work out what's going on? Or is there a bug in the firmware for using custom APNs? Please help.

1 Answer

0 votes
by anonymous

First of all, I would like you to check if the SIM that you're using and tried inserting into two phones, isn't a SIM that should go only into phones? Some of the operators limit their unlimited data plans only to smartphones and do not allow people to abuse them with modems.

Have you tried inserting it into another LTE router?

Anyway, you could try manually connecting to the operator by going to Network > Mobile > Network operators and just try to connect to yours when it's scanned and found.

If you're still unable to connect, check your router's model number, maybe the one that you bought isn't compatible with the regional ISP service.

by anonymous
Thanks EB for the response. Sadly, it's not the SIM. I'm working directly with the mobile provider and when we switch the SIM over to their default internet APN and the RUT955 to Auto APN, or select that APN, it works just fine. When we switch the SIM over to the custom APN and the RUT955 over to the correct custom APN, or even as Auto APN when the SIM only supports the custom APN, then it doesn't work. The mobile provider can't see an associate with that custom APN, so it's either not trying or it's failing in some way. The same test on several phones works just fine. It seems to be a problem isolated to the RUT955, but we going to try another RUT955 and hopefully a non-Teltonika router.
by anonymous
Understood, please let me know of your results with other routers.

If you isolate the issue only to RUT955 - I will ask you to download the troubleshoot file, but for now please try other routers.

by anonymous
We are having the same issue. We got one rutx11 to work with our ATT sim and custom APN. But we can’t get it to work on any other rutx11. The SIM cards all work in that one rutx11 but none of the others. Let me know if you found a solution.