10891 questions

12977 answers


26256 members

+1 vote
164 views 5 comments

I recently updated my RUT955 from to version. Before the updated I've some scripts into /root folder and I've installed some additional packages like a rsync, openssh-client. With updating, checking the option to keep configuration, the root folder is empty and the additional packages aren't installed. My custom ssh keys has disappeared too.

Does the upgrade procedure always remove manually installed packages from opkg? The root folder and the ssh keys?

Is there a way to install packages so they don't disappear after firmware update? Is there a directory where to store my personal scripts so that they are not deleted?

Thanks in advance.

1 Answer

0 votes

Thank you for contacting .

I am attaching a manual for you.

You will see some scripts in the manual for keeping data save even after firmware upgradation.

You can find it attached in you PM. Click on my username you will be redirected to my PM.

I hope it helps.

Thank you.

Have a good day.



Thanks for the manual.

But the manual doesn't describe how to keep the packages installed with opkg after a firmware update.

It is possible or I should do some trick with sysupgrade.conf and the directory where the ipk are installed?


Scripts would be lost after the firmware upgrade .

But packages won't be lost.

No need to do anything for keeping packages , only keep settings when upgrading the firmware.

I have also tried it on my side just to double check and packages i installed are there after the upgrade.

Ok, I'll checked again with another device. I think I remember that I installed rsync and after the update it was not available, but now I doubt so I'll check it again.

Packages are also lost.

We require the package ip-full and after an upgrade its gone and has to be re-installed.

Similarly for openssh-sftp-server.



I am facing the same error. And I thought it was my device problem, and I lost all of my mod ios data of picsart. Can anyone please guide me on how can I fix that and recover my files?