FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

12012 questions

14294 answers

22535 comments

35936 members

0 votes
267 views 2 comments
by

Hi folks

FINALLY got my split tunnel working but need static routes to do it 

I created them in the CLI and I know that it works . Then I rebooted, and they were not 
persisted. OK - lets use the GUI :


OK - 4 created - [SAVE and APPLY] - Configuration applied 

Ping the remote vpnhosts - nothing , nada, zip !!!

Check the routing table in the CLI :

And there they......aren't ?????

What gives ? 

It could be argued that I need to reboot ? ([EDIT] Just tried it - it didn't fix the problem! ) but I don't need to reboot for route add -net

in CLI so why should I have to reboot to apply static routes via the gui ?

[EDIT] Routing table after reboot: 



It seems this is a MASSIVE Flaw ? a router that cannot static route ???? OOPS! 

Regards 

BB

by

As proof that my observations are correct and there is no issue in my config / the underlying OS

I am SERIOUSLY SHOCKED ! 

regards

BB

by

And if the above wasnt embarrasing enough for Teltonika

I tried to login today via the VPN and found it down 
 

I got the driver to VPN his laptop into the office and used remote desktop into the router

This was what I found 



That's right - not only were the static routes not working, but something had deleted them
from the GUI ???


If this were my product, I would only have considered releasing this firmware as alpha - I would be glowing
red with embarrassment that it had found its way into production devices!


Regards

the #speechless

BB

 

1 Answer

0 votes
by
Hi,

I wasn't able to reproduce your issue as my added static routes were there and they were working (and they were in the table when i executed route -n). Even after the reboot, my route was there and didn't disappear anywhere.

Could you please tell me, have you updated to 07.00 with kept settings or was that a clean install without keeping the settings?

Also, there were no additional reports around this issue of yours, so it seems that you're alone who's having this issue. Please reflash your router with the same firmware without keeping the settings and try configuring everything again, as I can't reproduce the issue.

EB.