FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

12734 questions

15123 answers

24273 comments

47338 members

0 votes
170 views 11 comments
by
As long as I have 1 wireless client profile, I can set failover mode to use wireless as the uplink with a fallback to mobile.

When I add a second wireless client profile, it no longer connects to wireless. In fact the wireless connection (even at full strength) doesn't even get an IP address anymore (and as a result can not ping to do the failover).

Any ideas what would be causing this ?

Using an RUT-360 with the latest firmware.

1 Answer

0 votes
by
Hello,

For the issue, you are having could you elaborate on what you want to do. From the information you shared you want to have multiple wireless stations? Or it's a different thing? Kindly share with me a drawing or sketch of the solution you want to implement.

A copy of the troubleshoot file also will be an additional help.

Regards,
Mellow
by
Hi,

The device is in a vehicle that moves between different hubs. At each hub there is a wifi connection, but the SSID is different in several of them.

So the goal is to :

- Connect to the available wifi when the vehicle is at a hub location

- Failover to mobile when the vehicle is on the road

This works fine for a single wifi client setup, but as soon as I add a second, it will not connect to any wifi anymore and remains on mobile.

Kind regards,

Wim
by

Hello, 

If I am correct you want to prioritize the Wireless network in the area where you parked the car and use Sim card when it is traveling right? In order to do so, you need to scan and connect the device first in the wireless AP in the different areas so that it will be automatically connected. 

So you need to connect the device in the said different networks then configure the Failover option kindly check the attached screenshot.

Wireless Settings: https://prnt.sc/1kwbjl5



Failover Settings:  https://prnt.sc/1kwbeur


Note: I tested with Wired Network and two different hotspots in your case if you are using Sim cards you need to use the Mobile interfaces :) 

Regards,
Mellow

by
Thanks, that's exactly what I tried.

As long as I have only a single wireless network, it connects. However, as soon as I add a second wireless network, the "Device status" remains "Running", but the "Interface status" remains "Offline" on all of them.

It seems it's creating a bridged interface between the different wwans in that case.
by
Hello,

Hmm.. I have tried it on my side yes you are correct it only activates 1 Wireless Station the other one will not work because it will serve as a failover network. Let say since you are far away from the said Wireless networks there shouldn't be any problems with that but it would be best if you can test it in the real scenario.

Let me know the results :)

Regards,
Mellow
by
Hi,

In my case it actually won't activate any of the Wireless Stations. So it's odd that it actives 1 for you.

Both wireless networks are kilometers apart, so it wouldn't switch between them. Sadly, it won't even connect to any single one of them. Not really sure how to solve this.

Kind regards,

Wim
by

Hello, 

Could you try this scenario. Connect to the Wireless network first then connect to the other location wireless network then configure the failover between SIM card and Wireless network. It will automatically prioritize the wireless network whenever it is available. 

I have done my test using my personal hotspots in the phone. Whenever the other one is out of range it will automatically select the available wireless network. 

How to Enable WiFi WAN on Teltonika Networks Routers - YouTube

It is best to test it in an actual scenario.  Let me know when you have tested it. 

Regards,
Mellow

by
Sadly that's exactly what I did : I scanned for 1 network and connected to it. Then I drove to the other place, added that one, but then neither network would work anymore.

Would you be able to share part of your configuration file ? Maybe I can compare with what I have and see where it might differ.
by
Hi,

Could you share with me a copy of your troubleshooting file? So that I can check also. :)

Regards,
Mellow
by

This is what it looks like right now :

by

As you can see, there is a wifi connection active, but in the failover screen the status is Offline, even though it is at the top.

When I log in via the CLI and do 'ip a', I get :
So even though the connection is active, it doesn't seem to get an IP. As soon as I remove the second wifi, it works just fine.
by
Hello,

Could you share with me a copy of the troubleshoot file of the RUT360 where you connected both Access Points in different locations?
I will need to check the configuration you made.

Regards,
Mellow