8298 questions

9759 answers

15542 comments

13863 members

0 votes
40 views 2 comments
by
Hi,

I am trying to read information from a RUT240 using Modbus. This is returning an exception response whenever I try to read register numbers 88 or higher (i.e. the currently active SIM card slot, or data beyond this). This means I cannot read the WAN IP address which is what I would like to do.

Is this a bug?

Thanks
by
Hi,

I regressed the firmware to 1.14.1 but that did not help. I then regressed it to 1.10 and that seemed to make things better but the IP address was still being reported as 0.0.0.0 even though it was assigned in the WebUI. I then reinstalled 1.14.3 and the Modbus monitoring seems to work correctly now.

It's strange, but I now have a solution - but if anyone has any similar experience or can shed any light on it then I'd be interested to hear it. Note that my modem did not ship with 1.14.3 installed, so that was an upgrade that I did before I started configuring the modem.

Thanks

1 Answer

0 votes
by
Hi,

I am glad that you have solved the issue by yourself. I would like to ask if it works as expected even now? So far, it is hard to tell what was wrong because I have tried to read registers from my own RUT240 and the latest firmware version (it worked as expected).

Regards.
by
Hi,

Thanks for your reply. Whenever I tried to read any registers at or above 40088 the RUT240 would return exception code 04.

Another thing that is a bit awkward is registers like the signal strength and current wan ip address take on a particular number (I forget the number, but it is something like 231), rather than something more expected (for example 0 for the IP address).

Thanks