FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
264 views 4 comments
by anonymous

Hi, I am using TRB145 with firmware version TRB1_R_00.02.06.1. I am testing HTTPs connection to send Modbus data in the form of JSON to https://myjson.live/my-topic-name but have not received anything. What may be the problem?

1 Answer

+1 vote
by anonymous
Hello,

Could you share your configuration details right here (blur out sensitive information such as IP)? Also, would you mind testing with 7.0 firmware version?

Regards.
by anonymous
Hi, I tested with the latest version it is working.

Is there any way to differentiate the JSON payload if the sensor has multiple instances? The present payload for a single instance is like {"data": [293, 661]} with the first one being temperature and the other one being humidity. For individual instances, it will be {"data": 293} and {"data": 661} is there any way to differentiate them like {"data1": 293} and {"data2": 661} or in single instance {"data1": 293, "data2": 661}?
by anonymous

Hi,

Please refer to JSON format settings: https://wiki.teltonika-networks.com/view/TRB145_Data_to_Server#Advanced_Sender_Settings

Unfortunately, it is not possible to separate data or insert phrases/words between it.

Regards.

by anonymous

Hi, I observed although the payload is of JSON format date (%d) is displayed as {"date": 24/09/2021 16:34:11} which is not a valid JSON it should be {"date": "24/09/2021 16:34:11"}. And if we use Slave IP (%p) and used Modbus serial the payload is like {"slaveIP": } which is also not a valid JSON it should be something like {"slaveIP": ""}.

Why is that so?

by anonymous
We need to put "" explicitly to make it work like {"date": "%d", "slaveIP": "%p"}.