FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
285 views 3 comments
by anonymous
I have the RS485 port working as UDP client, but i would like to control when a packet is send. At the moment, when i send data at 115200 baud, it looks like the TRB145 sends a packet of 260 bytes after 25ms. Is there a way to make it wait a bit longer (150ms) so i can fill a UDP packet most optimally to 1400 - 1500 bytes?
by anonymous
Hi, I am currently analyzing your requirement and shall get back as soon as possible. Thanks.
by anonymous
On a related note, the 460800 baudrate does not appear to be working. If i set it, it still communicates at 115200. even after a reboot. `stty -F /dev/rs485 460800` via SSH does change the baudrate, but that is of course lost at reboot

2 Answers

0 votes
by anonymous
For the baud rate not working at the specified rate please share to me the troubleshoot file. Also, Please let me know if the in the RS485 configuration page please flow control option has been tried / set to cause the required delay ?

Thanks
by anonymous
Please ignore the baudrate problem for now. Did you already find some info about the UDP packet timeout?
0 votes
by anonymous
Hi, Please let me know if in the RS485 configuration page flow control option has been tried / set to cause the required delay for the UDP packet timeout ? Thanks