10947 questions

13051 answers

20353 comments

27724 members

0 votes
112 views 3 comments
by
I have the RS485 port working as UDP client, but i would like to control when a packet is send. At the moment, when i send data at 115200 baud, it looks like the TRB145 sends a packet of 260 bytes after 25ms. Is there a way to make it wait a bit longer (150ms) so i can fill a UDP packet most optimally to 1400 - 1500 bytes?
by
Hi, I am currently analyzing your requirement and shall get back as soon as possible. Thanks.
by
On a related note, the 460800 baudrate does not appear to be working. If i set it, it still communicates at 115200. even after a reboot. `stty -F /dev/rs485 460800` via SSH does change the baudrate, but that is of course lost at reboot

2 Answers

0 votes
by
For the baud rate not working at the specified rate please share to me the troubleshoot file. Also, Please let me know if the in the RS485 configuration page please flow control option has been tried / set to cause the required delay ?

Thanks
by
Please ignore the baudrate problem for now. Did you already find some info about the UDP packet timeout?
0 votes
by
Hi, Please let me know if in the RS485 configuration page flow control option has been tried / set to cause the required delay for the UDP packet timeout ? Thanks