subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
599 views 0 comments
by anonymous

Hello everyone,

I have several RUTX14 (and RUTX12) routers.

These routers are interconnected by an openvpn TUN (layer 3) network.

On the LAN side of each router, one device joins a multicast group. This group must be common to all local networks. So it has to be forwarded in both directions over the VPN network (2 hops).

Unfortunately, unless I missed something, there doesn't seem to be a menu to configure PIM, igmpproxy... or smcroute via the web interface.

So I tried installing pimbd via the CLI using opkg install pimbd.
When I run pimdb, I get the following errors:

root@Teltonika-RUTX14:~# pimbd
 pimbd: Unexpected sysctl value: /proc/sys/net/ipv6/conf/all/mc_forwarding = 0
 pimbd: Unexpected sysctl value: /proc/sys/net/ipv4/conf/all/mc_forwarding = 0
 pimbd: Unexpected sysctl value: /proc/sys/net/ipv4/icmp_echo_ignore_broadcasts = 1

While I manage to set icmp_echo_ignore_broadcasts to 0,
I cannot set mc_forwarding to 1 for either ipv4 or ipv6.

The following commands are ignored:

root@Teltonika-RUTX14:~# sysctl -w net.ipv4.conf.all.mc_forwarding=1
root@Teltonika-RUTX14:~# sysctl -w net.ipv6.conf.all.mc_forwarding=1
root@Teltonika-RUTX14:~# cat /proc/sys/net/ipv4/conf/all/mc_forwarding 0
root@Teltonika-RUTX14:~# cat /proc/sys/net/ipv6/conf/all/mc_forwarding 0

I have also tried setting these variables in /etc/sysctl.conf, but the values remain unchanged even after a reboot.

Please, could you help me to make a bidirectional multicast forwarding ?

1 Answer

0 votes
by anonymous

Unfortunately we do not have instructions for this, but maybe this article could help to you: