FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
691 views 5 comments
by anonymous
We have a ISP that provides access using DHCP, so we have to set up WAN DHCP client.

Unfortunately the Teltonika routers are not able to resolve an adress. Testing with other routers or even only with a PC we get an IP and connection without problems.

I tried a RUTX08 and a RUTX10. Even with different firmware versions (newest and also older one). Of course we tried the factory reset but everything without success.

It brings up the link on the WAN, but then we get udhcpc: sending discover and then ubi0 error: ubi_open_volume.part.0: cannot open device 0, volume 2, error -16

Attached the troubleshoot from the RUTX08 and RUTX10 and a picture of the system log.

1 Answer

0 votes
by anonymous

Hello,

Please make sure that the firewall on RUTX08 and RUTX10 isn't blocking DHCP address renew from WAN. Double check if the necessary traffic rule is enabled by navigating to "Network>Firewall>Traffic rules" and please make sure that the "Allow-DHCP-Renew" is turned on.

Additionally, if the traffic rule is enabled and your devices still cannot obtain lease, please proceed to reinstall firmware by using the Bootloader method as described here: https://wiki.teltonika-networks.com/view/RUTXxx_Firmware_via_The_Bootloader_Menu

If the issue isn't solved after these steps, please send me a private message with the troubleshoot file and include any related screenshots when trying to obtain the IP address via DHCP (give router some time to send a few requests).

Best regards,

Tomas.

by anonymous
Dear Tomas,

I did try to do as you suggest, Allow-DHCP-Renew is turned on.

In fact I get DHCP Adress from lot of routers but in particular not from the ISP that we use. I did also try to use another RUTX08 but with no success. There is something on the DHCP snooping process that does not behave correctly.

As told before, If I test the ISP with a common PC (Windows 10) or with a Frixbox asking for DHCP IP assignment I get the IP without problems.

I did not try the same with a RUT240, but same issue.
by anonymous

Hi Tomas,

Im new to Teltonika so please excuse if I'm breaking the rules asking a question here. But very similar issue.

I have the same problem with my new RUTX08 (running RUTX_R_00.07.02.7 ) I cant get a DHCP address from my ISP on the RUTX08 WAN port if set for DHCP. Existing Ubiquiti Router (USG) gets a address ok, and if I just plug the RUTX08 WAN port into my current internal network it gets a IP address configured on the WAN port and all ok. But it wont get one off the ISP interface (NBN Fixed wireless CTD device). I want to replace my existing USG router with the RUTX08? . Other "home" routers ASUS etc , have no problems getting assigned address from the NBN device ?

regards,

furry040

by anonymous
Hi,

Was your issue resolved? And how? I'm having the exact same issue with the RUT240 both on the latest firmware (7.04.2) and old (1.14.6).

Other router and pc works without an issue on this isp (starlink dishy)

Thank you.
by anonymous
Unfortunately I did not find any solution to the problem using the RUT240.
by anonymous

Hi,

Yes my issue was resolved. I feel a little stupid I didn't think of it.  I had to leave the network connection (WAN) cable out of the NBN router (the ISP interface) for 30+ minutes, and let address stale out. Put the cable from the RTUX08 back in to the NBN connection now its all good, got the same address as my old USG router. Clearly I had to let the NBN router "stale" out the address . 

regards,