FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
939 views 4 comments
by anonymous

Thought I'd check my logic on this setup just in case I was opening up a can of worms for myself later.

We have a RUT360 which we've flashed back to the factory default RUT36X_R_00.07.00 FW due to problems with the 7.01.2 version failing to passthrough the IP to the connected router.

Because we're using Three and it gets given a non-public IP address on the mobile connection we've adjusted the WAN to be a LAN port as follows:

  1. Turned off WAN6 interface
  2. Edited WAN interface to
    1. General > Protocol: Static
    2. General > IPv4 address to local LAN ip different from LAN port
    3. Physical > Bridge Interfaces: On
    4. Physical > Interface: eth1
    5. Firewall > Create /Assign firewall-zone: lan (Lan/Wan)
    6. DHCP > Enable DHCP: Enable
    7. DHCP > Start: 2
    8. DHCP > Limit: 1
  3. Mob1S1A1 (mobile) interface to:
    1. Mode: Passthrough
    2. MAC Address: [To router MAC address]
    3. Firewall > Made sure firewall-zone is set to wan (wan6/mob1s1a1)

Beyond that connected the main(external) router WAN port to the RUT360 LAN port (port 1) and the WAN port to my spare Ethernet port on my PC.

This setup allows me to access the RUT360 to access the UI while allowing the mobile connection to work uninterrupted via the main router.

Anyone got any comments on whether this is best practice or if there's any tweaks to make?

1 Answer

0 votes
by anonymous

Hi, 

Sorry for the late response I tried replicating the issue you are having about the passthrough mode but it is working fine for me, tested it using the 7.01.2 Firmware for RUT360. 

Kindly try doing a firmware upgrade without keeping the settings and see if Passthrough is still not working as you expected.
 
On the other hand, as what you are trying to achieve, I tried following your guide but the WAN interface doesn't go up that is why I have another approach using VLAN's.

Here are the steps: 

1. Navigate to Network > VLAN > Add a VLAN Interface "VLAN 10"

Tag is set to 10 and Parent Interface is eth0 then Save Settings. 

2. After configuring VLAN, navigate to Network > Interfaces and disable WAN and WAN6. 



3. Next, go to Network > Interfaces > Add a new interface "VLAN 10"



- Set protocol to Static"
- Set the IP address to 192.168.X.1 other than the LAN Network you have. 
- Set Physical Interface to Bridge
- Set Interfaces to be VLAN 10 and eth1
- Save configuration

After doing so if you insert a LAN cable on WAN Port to your PC it will automatically assign an IP address of your PC which you can reach the device from 192.168.X.1 you assigned and the device LAN IP as well on LAN 1. 

Also, when you are using passthrough mode connect the device you want to assign the IP address on LAN 1 not on the WAN port to prevent issues. 

I hope this helps. 

Regards,
Jerome

by anonymous
Do we need DHCP on the VLAN10 Interface for this to work? Or will it assign an IP from the original LAN range when plugging the PC into the WAN port?
by anonymous
Also one more question: After activating the passthrough mode on the Mobile Interface to a specific MAC-address-device, do you need to reboot RUT360 before these changes take effect?

I didn't reboot because I wanted to avoid receiving a new public IP via my Mobile provider, but I don't see changes in behaviour, after clicking save & apply. Still need to have my port forwarding in the Firewall for my internal device to receive from outside. When I delete the port forwarding, the internal device is unreachable. Shouldn't the internal device have the external IP now and receive anything?
by anonymous
And finally: Am I losing RMS connectivity to my RUT360, if I activate passthrough on the Mobile interface?
by anonymous

Hi, 
 

Do we need DHCP on the VLAN10 Interface for this to work? Or will it assign an IP from the original LAN range when plugging the PC into the WAN port?
-> Depends on you you can assign it statically but it would be best if you do it on DHCP. 

Do we need DHCP on the VLAN10 Interface for this to work? Or will it assign an IP from the original LAN range when plugging the PC into the WAN port?
-> Usually I am just rebooting the device connected to it. If it doesn't work I am restarting both of the devices. 

Do we need DHCP on the VLAN10 Interface for this to work? Or will it assign an IP from the original LAN range when plugging the PC into the WAN port?
-> By default, the router will still have network connectivity, by default it is supposed to be reachable with RMS. But it's best to do test it on the live scenario. 

Regards,
Jerome