FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
714 views 3 comments
by anonymous
Hi,

as we can't get the OpenVPN server of the RUT240 to work, because there were issues to get an IP address, we try to use the OpenVPN cloud.

We made an account which allows 3 simultan connections for free. We tested it with a PC, laptop and smartphone, works.

We disconnected the stuff and download the .ovpn files from the 'owners portal'.

I loaded the .ovpn file into the router, setup as a client. Nothing happens.

I loaded the .ovpn file in the router, setup as a server. The device starts up connecting but fails .

I include a trouble shoot file here.

Has anybody setup a RUT240 as an unintended device part of a OpenVPN cloud and was anybody able to connect a PC/Laptop to a device connected to the private network (LAN/Wifi) of the RUT240 using mobile internet?

By the way, WiFi (private network) works fine, but mobile internet is a mess.

We just need the RUT240 and a SIM card to have mobile internet and want connect to one device which is connected to the LAN of the RUT240. We want to have a remote measurement system which should be monitored from our stuff in the office/lab using VNC (over VPN).

I think this is a quite common scenario for an industrial router, isn't it?

With best regards

Gerhard
by anonymous
Dear Gerhard,

I have the same scenario as you. Did you solve this scenario ?

Best regards,

Pat

1 Answer

0 votes
by anonymous
Hello,

We have tested OpenVPN cloud on our devices and I can confirm that it works on RUT240 with no problems, when the stadard OpenVPN cloud connector.ovpn file is uploaded to the configuration on the client.

It looks like you have issues with IPv6 settings:

Linux can't add IPv6 to interface tun0

IPv6 is a requirement for the connection to the labs. You are receiving this error because IPv6 is currently turned off for your LinuxOS.

Solution:

If you see 0 at cat /proc/sys/net/ipv6/conf/all/disable_ipv6 that means you have it enabled, if you see 1 you can enable it by pressing the sysctl net.ipv6.conf.all.disable_ipv6=0 command.
by anonymous
Hello all,

I have also tried unsuccessfully to use OpenVPN Cloud on my RUTX12.

Since it is really easy to configure and start the pre-installed OpenVPN on the RUTX12, I thought it would be easy to install and run an OpenVPN Cloud client on the RUTX12.

So I tried the following:

Create an OpenVPN Cloud environment with three clients (one each on my Windows laptop, my iPhone and my RUTX12).

The clients on my laptop and my iPhone worked fine.

I created and tried the required certificates with the certificate creation option provided by OpenVPN, an OpenSSL CA on my laptop, as well as the option available on the RUTX12.

Result:

The OpenVPN Cloud client could be installed on the RUTX12 but could not be started.

I tried to connect the OpenVPN on the RUTX12 to my OpenVPN server without success. The settings for TCP/IP v4 or v6 do not solve the problem. This is because the OpenVPN server can be reached via the CLI on the RUTX12.

Then I tried everything I could think of to get the OpenVPN Cloud client running on my RUTX12 and connecting to my OpenVPN server.

I have also discussed this with some people who are much more familiar with Linux and network services than I am. But no one had the slightest idea how to solve the problem.

After I opened a support ticker at Teltonika, which unfortunately remained unanswered, I gave up and stopped my activities.

Since Teltonika offers a paid VPN cloud solution with their RMS, with which one can access the router, I believe that Teltonika is not willing to provide an OpenVPN cloud solution (which is free for up to three clients).

That would be enough for a lot of users and why would anyone want to pay for RMS?

If someone who has more light on the bike than I do is able to get the OpenVPN cloud client running on a RUTX##, I would be happy if he or she could tell me how to do it and what to do. A step by step guide would be absolutely great, so thank you in advance.

Dieter
by anonymous

Hi,

We do not limit any 3rd party services in any way shape or form.

It's quite strange as to why the OpenVPN cloud would not work in your case.

Just to make sure that it does work, I created fresh .ovpn file on the platform, downloaded, added one to PC, another one to a RUTX50 (had one lying on the table) and tried to make a connection.

Router logs of successful cnnection

Thu Mar 16 09:46:01 2023 daemon.notice openvpn(OVPNCLOU)[13800]: add_route_ipv6(fd:0:0:4000::/50 -> fd:0:0:8100::1 metric -1) dev tun_c_OVPNCLOU

Thu Mar 16 09:46:01 2023 daemon.notice openvpn(OVPNCLOU)[13800]: net_route_v6_add: fd:0:0:4000::/50 via :: dev tun_c_OVPNCLOU table 0 metric -1

Thu Mar 16 09:46:01 2023 daemon.notice openvpn(OVPNCLOU)[13800]: Initialization Sequence Completed

root@Teltonika-RUTX50:~# ping 100.96.1.3

PING 100.96.1.3 (100.96.1.3): 56 data bytes

64 bytes from 100.96.1.3: seq=0 ttl=127 time=71.625 ms

64 bytes from 100.96.1.3: seq=1 ttl=127 time=74.380 ms

^C

--- 100.96.1.3 ping statistics ---

2 packets transmitted, 2 packets received, 0% packet loss

round-trip min/avg/max = 71.625/73.002/74.380 ms

root@Teltonika-RUTX50:~#

As you can see at the end, I was able to ping a client on the other side of OpenVPN cloud network

Also, in the WebUI, it shows connected

Devices are also shown online in OpenVPN could interface

So we are definitely not blocking anything most likely your ISP is blocking some traffic and I would check with them first