10456 questions

12460 answers

19384 comments

21896 members

+1 vote
116 views 3 comments
by

As far as I know the commands are:

  • uci set simcard.@sim[0].band='manual'
  • uci set simcard.@sim[0].lte='lte_b20'
  • uci set simcard.@sim[0].umts='wcdma_900'
  • uci commit simcard
  • /etc/init.d/simcard restart
  • reboot

But after the reboot the modem still sticks to b1 instead of b20 (or 3g if b20 would not be available)

If I do the change via the web interface than it works and the output looks like: root@Teltonika-RUTX09:~# uci show simcard

  • simcard.@sim[0]=sim
  • simcard.@sim[0].modem='3-1'
  • simcard.@sim[0].position='1'
  • simcard.@sim[0].primary='1'
  • simcard.@sim[0].pincode='1234'
  • simcard.@sim[0].auto_apn='0'
  • simcard.@sim[0].enable_sms_limit='0'
  • simcard.@sim[0].service='auto'
  • simcard.@sim[0].band='manual'
  • simcard.@sim[0].umts='wcdma_900' 'wcdma_2100'
  • simcard.@sim[0].lte='lte_b1' 'lte_b28' 'lte_b38' 'lte_b41'
  • simcard.@sim[1]=sim
  • simcard.@sim[1].modem='3-1'
  • simcard.@sim[1].position='2'
  • simcard.@sim[1].auto_apn='1'

My manual config looks like: root@Teltonika-RUTX09:~# uci show simcard

  • simcard.@sim[0]=sim
  • simcard.@sim[0].modem='3-1'
  • simcard.@sim[0].position='1'
  • simcard.@sim[0].primary='1'
  • simcard.@sim[0].pincode='4798'
  • simcard.@sim[0].auto_apn='0'
  • simcard.@sim[0].enable_sms_limit='0'
  • simcard.@sim[0].band='manual'
  • simcard.@sim[0].umts='wcdma_900' 'wcdma_2100'
  • simcard.@sim[0].service='auto'
  • simcard.@sim[0].lte='lte_b20'
  • simcard.@sim[1]=sim
  • simcard.@sim[1].modem='3-1'
  • simcard.@sim[1].position='2'
  • simcard.@sim[1].auto_apn='1'

BR Toine

1 Answer

0 votes
by

Hello,

You are using uci call not correct.

First you need to set like list not option bands. That's why you commands not working. Here is solution:

  • uci set simcard.@sim[0].band='manual'
  • uci delete simcard.@sim[0].lte
  • uci add_list simcard.@sim[0].lte='lte_b20'
  • uci delete simcard.@sim[0].umts
  • uci add_list simcard.@sim[0].umts='wcdma_900'
  • uci commit simcard
  • /etc/init.d/simcard restart - (you don't need this command)
  • reboot - (You don't need to restart all router to get applied changes. You could restart only module with `mctl -r` command or just re-init modem AT commands by using `ubus call gsmd reinit_modems` command.)

by

Many thx, this works perfect via CLI. 

Next step is to get it working via SMS. Working is:

  • uci set simcard.@sim[0].band=manual (or auto)
  • uci commit simcard

Not working is:

  • uci delete simcard.@sim[0].lte
  • uci add_list simcard.@sim[0].lte='lte_b20'
  • uci delete simcard.@sim[0].umts
  • uci add_list simcard.@sim[0].umts='wcdma_900'
SMS not accepted is:
  • `mctl -r` or
  • `ubus call gsmd reinit_modems` 
What do I have to change to get it working, Why do I use SMS?, because than I can reach the modem if LTE is down.
BR Toine
by
Hello,

Yes, this is shell commands and SMS-utils don't execute shell directly.

I suggest to create a 2 different profiles and switch them between if needed.

I think that SMS-utilities doesn't have anything to restart modem directly, so best options at this moment is restart device with SMS-utilities restart command.
by
Goodmorning,

Is it an option to generate a CLI link via the RMS API (/devices​/{id}​/connect​/cli) and then perform these actions?

BR Toine