10948 questions

13053 answers

20356 comments

27889 members

0 votes
319 views 10 comments
by
Hi there,

I enabled forwarding of NMEA data to the tcp server, but the only way I can see it upload to the server is if I set up the RS232 port as a tcp “server” mode with the same port, send the data out first, and receive it back. For my application I would like the NMEA data to upload directly to the tcp server address, but be able to periodically send packets to the same port through RS232/485 to as well. Please advise if this is possible with the RUT955.

Alternatively, if the device has to receive the NMEA data in order to forward it to the TCP server, is it possible to have both RS232 and RS485 simultaneously enabled and uploading to the same sever port, so that I may use one for the NMEA data and one for additional packets?

Any guidance would be greatly appreciated. Many thanks in advance!

1 Answer

0 votes
by
Hello, this is Martín, Tech Support Engineer for Teltonika Networks.

NMEA Forwarding only works with one single hostname.

Which firmware version are you using? Do you have any diagrams that might help us understand your setup? Could you also share the configuration you are using?
After we have this information we will be able to help you more in depth, as we can completely or partially replicate your setup and test the configuration here.

Best regards.
Best answer
by

I have the following configuration settings for the GPS/NMEA (firmware is RUT9XX_R_00.06.07.7)

Hostname: TCP server IP 

Port: TCP dedicated port 

Protocol: TCP

However, when I open Wireshark on the respective server and port #, I don't see any NMEA packets coming through (I have tried both TCP and UPD). I see a lot of NMEA forwarding examples on the forum using the router IP (192.168.1.1 port 8500) instead, am I misunderstanding something? Ideally, I wish to have NMEA data streamed directly to the TCP server address I provide, as well as send additional packets periodically to the same server through a device connected via serial. Many thanks for your help.

by

Hello,

I still can't fully understand the setup you have and what you are trying to achieve, so I will need a detailed diagram of all the devices involved in your setup, as well as a backup from your device.

The device's backup file can be obtained with the steps detailed here, and you can attach it by editing the original question you have made.

Once I have that information we will be able to proceed further.

Best regards.

by
I've attached a diagram I made up of the setup we are attempting to use to the original question. Hopefully it makes things a little clearer. The backup however is 15MB in size, so I wasn't able to attach it as it exceeded the file size limit. Please let me know how I can send it to you.
by
Hello, I received and reviewed the diagram you have attached. For attaching the backup, you can use software such as WinRAR and split the file into smaller sized files to attach them, or use a website such as WeTransfer to upload the file an attach a link to it.

We have replicated your setup over here, by having simultaneously the NMEA Forwarding, an RS232 and an RS485 device connected trough Serial-Over-IP (both in client mode) all to the same IP and Port 4000, and now I can confirm the RUT955 is capable of this, as we successfully received all the information on our server.

I will continue my answer in the following comment.
by

This leads me to believe there is a potential issue in the server receiving the information. As you are trying to receive both NMEA data and the serial console links under the same port, have you checked in your server logs if your application blocks the usage of said port for other applications? This might be the issue in question, as we have now confirmed that the RUT955 is capable of sending this information to the same IP/port, but you are reporting that you do not receive it correctly.

Also, you should check if there is a firewall blocking or partially obstructing the inbound connections to the server on port 4000, as this might also be the issue.

I'm attaching a screenshot here from the Hercules software which shows the reception of messages trough RS232, NMEA and RS485.

Best regards.

by
Thank you very much for your detailed investigation into my problem. Could you share a little bit more info on your configurations? Screenshots of the "RS232" "RS485" and "NMEA" tabs in the WebUI would be very helpful to confirm that there are no issues with my configuration before looking into my server potentially blocking the packets.

Please let me know if the following link allows you to download the restore point for my configuration:

https://wetransfer.com/downloads/3c01a76085f7efe55322ec5879628de520220316170200/3bf299ec458b199c5e9978b2309657a920220316170214/c8c319
by

You are very welcome, and I have attached the screenshots here:

NMEA Settings
RS232 Settings
RS485 Settings

However, I don't seem to be able to open the file you sent me as it's an ".rp" extension, and backup files should be ".tar.gz"

I'll be waiting for your comments.

by

I just followed the instructions in your attached link: https://wiki.teltonika-networks.com/view/RUT955_Restore_Point_(legacy_WebUI) and it auto-generated as an .rp file(which is as the link describes).  Also, I duplicated the configurations in your screenshots but Hercules still showed me no connections, and an error when I tried to connect to port 4000 via Hercules as a client (see below screenshot). I tried disabling Windows firewall, and adding a rule to permit all connections to port 4000 as well with no luck. Would factory resetting the router help?

https://wetransfer.com/downloads/1e0f1fa1415ac187a511a14f9e1adf1c20220316180254/ffafb28ae6fe76fae4d1d23a7d654bc920220316180314/06a7a4

by

Sorry for my mistake, RP files are used on the legacy firmware which I am less familiar with than the updated firmware.

I see you are using the Hercules software as a Client, and instead you should use it as a TCP Server listening to Port 4000 to receive the incoming connections from the clients.

Also, the IP address 192.168.1.117 was used here internally to test, and it's irrelevant to your configuration, as it was the computer's IP address for the device which was running Hercules. This should be replaced to 174.16.10.204 as this is the IP address you provided me in the diagram, and you indicated me this was the server's address.

I am also attaching a diagram which displays a more graphical description of what should be done on your setup.

Client's Diagram for the proposed solution

Best regards.

by

Thanks for the visual, it was very helpful. I set up everything as outlined above (except I used UDP instead since the server I was testing with had only a UDP port open). I was able to successfully receive the NMEA stream direct from the RUT955 client to the server, however I still haven't been able to make the RS232 work properly... I enabled the "echo" feature for debugging, and my COM port monitor shows the echo (see screenshot: https://wetransfer.com/downloads/e5c6156179f1e0237e5f29b287f203cd20220318171127/fc05c7218208e08a3375336ac1af33d920220318171148/67b71a ), however the server never gets the packets (verified through wireshark) although the configuration is exactly the same ad the NMEA streaming. Please advise if I have to enable something else or if you suspect another problem. 

Update: It appears that the RS232 messages are not even getting sent out, as when I don't see them appearing on wireshark on the sending side either..