subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
1,199 views 9 comments
by anonymous

I have RUTX11 working with a 4G mobile network, and connected to RMS

To this router connected raspberry and Windows PCs

When I'm trying access to one of the devices via RMS Connect  Remote desktop by VNC or RDP, I'm getting a Timeout message.

VPN and SSH are working correctly.

I'll be appreciated for your help

1 Answer

0 votes
by anonymous

I am going to try to replicate this issue to find out what might be going wrong. However, have you enabled the RDP functionality and port on both devices? It is possible that it is not active by default on the Windows PC. In the case of Raspberry, you must install some packages to be able to access RDP to it.
by anonymous

Access by RDP and VNC is active on both computers, and I can connect to them from another computer connected to the same network.
by anonymous

Hey Igor,

I have not been able to replicate the issue you are having with RDP or VNC. I am testing with a RUTX11 same as you, with the latest version, and have had no issue. Maybe you are having issues with monitoring credits? or internet connection on your computer? You can see in the image where the device is available to connect to with the green indicator. Can you see this on your created devices?

by anonymous

No Problems with  Monitoring points, I have enough

I tried several different ways to connect RUTX11 gateway to the internet with cable or with 3G(connected right now)- but the results are the same.

Additionally please see a link with a short record of what I facing when trying to access VNC

I'll be very much appreciated it if we can make a short meeting and find the solution to this issue together

by anonymous

Hey Igor,

The internet connection is not the issue you are having. This is because your device appears available for access. I have tried the VNC connection and the only timeout message I have is when I have to authenticate, and the password or user is incorrect. Can you try logging in without authentication? What software are you using to activate the VNC protocol? I am using TightVNC and I have no problem. Here is a link to their site if you want to try it.

by anonymous

I'm using RealVNC Server on Raspberry PI version 6.7.4

But I'm not sure that the issue related to the VNC

I tried to connect to the Windows via RDP protocol and got the same error of timeout

by anonymous

I think the issue has to do with the RealVNC Server configuration. I installed it on my PC and tried to connect. However, it does not show the device in green as available to connect. Maybe you can confirm that it works using TightVNC. Here is a link on how to configure it.

Also, try another VNC or RDP server on your Raspberry Pi. I think on Linux it is a bit more complicated to configure. However, here is a link on how to configure another server.

by anonymous
I already tried two different computers with Windows and Linux and got the same results.

Basically, I bought this gateway for POC, to check if I can provide remote support capability for controllers installed in many of our customers.

The capability of the RMS system is really good and can help us

But if I need to spend so much time and make many custom changes I think we will continue testing another solution

by anonymous

Hey Igor, 

For a remote session, you will need a Teltonika VIP Helpdesk account. For this, you will need to contact your Sales Manager. On the other hand, I can try to replicate my configuration on your devices. This is because I was able to use RDP and VNC on my device as I said to you before. 

First I would like to know if you were able to install TightVNC. If you were able to install it. Can you check the server configuration? Mine has the following configuration shown in the image. 

Note that Require VNC authentication is unchecked

Then it would be good to check your firewall. In general, it may block remote connection traffic to your PC. You can turn it off momentarily to do this test. 

Then in the RMS configuration, you should follow the following settings. With the IP assigned to your computer. You can recheck this, it is possible that reconnecting to the router has assigned you a different IP. You can see this through the CMD with the ipconfig command.

Note that the Network level authentication checkbox is unchecked. 

After this, the VNC connection should show green as available to connect. You can try it by clicking on connect directly. 

Can you verify these steps and send me evidence of your configuration? That way I can validate what you may be missing. Also please tell me what operating system you are using. My test was on Windows 11. It would be nice if we can try to replicate this test on a computer with the same operating system. 

by anonymous

Hey Alvaro,

Thank you very much for your support

After I installed TightVNC on Raspberry Pi, I successfully connected via RMS

I will continue testing the system 

Best Regards