subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
758 views 18 comments
by anonymous

Dear teltonika-team,

Blacklisting seems not working: 
After adding a new OperatorList (e.g. called "Swiss" which just one operator-number as an example e.g. 22801) and enabling the Blacklisting with this small list, the mobile-connection immediately stop working. 

Many thx for help,

1 Answer

+1 vote
by anonymous

Could you please specify your problem.

Blacklisting operators blocks all operators in that list, thus, if you have included the code of the operator you are currently using, consequently, you loose your mobile connection.

Best regards,

by anonymous
You see I'm connected to my operator otelo in germany with mcc/mcn 26202:

>>> gsmctl -o
>>> gsmctl -f

I have created an Operator-List called "Test" (with just one operator-number) as you could see below.
And after enabling/blacklisting the operator-list "Test" the mobil-connection is getting lost (so also via RMS I have no chance to connect anymore, also no more after a reboot):

>>> uci show | egrep oper
operctl.@operlist[0].mcc_mnc='22801' '22802' '22803' '22804' '22805' '22806' '22807' '22808' '22809' '22810' '22811' '22812' '22813' '22814' '22815' '22816' '22817' '22818' '22819' '22820' '22821' '22822' '22823' '22824' '22825' '22826' '22827' '22828' '22829' '22830' '22831' '22832' '22833' '22834' '22835' '22836' '22837' '22838' '22839' '22840' '22841' '22842' '22843' '22844' '22845' '22846' '22847' '22848' '22849' '22850' '22851' '22852' '22853' '22854' '22855' '22856' '22857' '22858' '22859' '22860' '22861' '22862' '22863' '22864' '22865' '22866' '22867' '22868' '22869' '22870' '22871' '22872' '22873' '22874' '22875' '22876' '22877' '22878' '22879' '22880' '22881' '22882' '22883' '22884' '22885' '22886' '22887' '22888' '22889' '22890' '22891' '22892' '22893' '22894' '22895' '22896' '22897' '22898' '22899'
by anonymous
After enabling and saving blacklisting settings, the router's modem gets restarted, thus connectivity is indeed lost, however, within a short period it should be reestablished.

Best regards
by anonymous
No, unfortunately the mobile-connection does not more work (despite reboot) until I DISABLE blacklisting.

Please see my uci-output above, for me it looks like ok.
Could you please check this on your own?

Thx for any help,
best regards, Rainer
by anonymous


Apparently there is indeed an issue with operator blacklist/whitelist functionality. It has been recently discovered and should be resolved in the upcoming major firmware release.

As of right now a link to the test firmware version can provided to you. However, before updating, make a backup of your current configuration, if you have important settings so that you could easily revert back. Also, before updating, make sure you that you disable Keep settings button.

You can download the firmware here.

Best regards,


by anonymous
Great thx for fast answer :-)
Any clue about date of next firmware release?
by anonymous
The firmware is finished and is currently undergoing testing. It should be released in the upcoming weeks, but the date depends on testing results and is not set yet.


by anonymous

With new FW (07.02.1) Operator-Blacklisting is working now - many thx - but modem seems crashing.

I blacklisted all Swiss-Operators and I let run a test/check while driving home from Italy via Swiss to Germany. 
"gsmct --operator" commands and "wan/internet" stopped working when entering Swiss - fine :-)
So gsmctl -o and gsmctl -f (operator-number) both throws the error "GSMCTL error: parsing output".
This error is a bit strange, since syntax is working when I'm connected to a whitelisted operator.

But when entering Germany the wan/internet of my sim didn't came back :-|
I checked my logfiles and saw that only after the next nightly router-reboot (back in Germany), the sim-connection came back (and gsmctl --operator command works again).

So, modem looks like "crashing" after entering blacklisted operator (and only a reboot/modemrestart helps).
Could you please help?

Many thx, Rainer

by anonymous

Thank you for the observation.

It would be helpful if the next time, when you entered Germany and the data connection did not establish, you generated the troubleshoot file. It might provide more insight into the issue. As a workaround, you can configure automatic modem reboot if the data connection is lost by navigating to Services -> Auto reboot -> Ping/Wget reboot in the WebUI. For more details refer to this page:

Best regards,


by anonymous

Hi, yes, modem-restart could evtl. be a workaround, but it's even worse and I fear Operator-Blacklisting still does not work :-|
I did a simple test, which could be done by teltonika-support too:

After a fresh router-start I added above mentioned Operator-Blacklist and immediately the active sim2 (my default sim) loses data-connection until next reboot. Before reboot the modem is switching between sim1 (not inserted) and sim2 which does not have any data-connection anymore. After reboot sim2 is working again.

Next test after fresh reboot is doing a simple "ubus call sim change" which switches to sim1 (not inserted) and fails back to sim2. Usually this is working well. But now sim2 cannot get data-connection anymore and sim1/2 is switching permanently. See logread-output:

>>> logread -f | egrep -i "sim|mob1|apn"
Tue Jun 21 22:05:42 2022 unhandler[2729]: modem_init[1-1.4][8]: get from gsmd '+CME ERROR: SIM not inserted
Tue Jun 21 22:05:46 2022 sim_switch[5808]: [1-1.4] SIM switch in progress. Triggered by data_fail rule
Tue Jun 21 22:05:47 2022 unhandler[2729]: modem_init[1-1.4][1]: get from gsmd '+CME ERROR: SIM failure
Tue Jun 21 22:05:50 2022 unhandler[2729]: modem_init[1-1.4][3]: get from gsmd '+CPIN: SIM PIN
Tue Jun 21 22:05:50 2022 unhandler[2729]: modem_init[1-1.4][3]: skipping CFUN calls, SIM detected
Tue Jun 21 22:05:50 2022 unhandler[2729]: modem_init[1-1.4][8]: get from gsmd '+CPIN: SIM PIN
Tue Jun 21 22:05:51 2022 unhandler[2729]: SMS-Utilities[src/sms_utils.c:161]: count_free_sms s->type: simman
Tue Jun 21 22:05:52 2022 unhandler[2729]: modem_init[1-1.4][3]: skipping CFUN calls, SIM detected
Tue Jun 21 22:05:52 2022 unhandler[2729]: active_sim:  |2|
Tue Jun 21 22:05:52 2022 unhandler[2729]: auto_apn:    |1|
Tue Jun 21 22:05:52 2022 unhandler[2729]: force_apn:   |0|
Tue Jun 21 22:05:52 2022 unhandler[2729]: Attempt to fetch APN list...
Tue Jun 21 22:05:52 2022 unhandler[2729]: Getting APN list from database
Tue Jun 21 22:05:52 2022 unhandler[2729]: SIM READY
Tue Jun 21 22:05:52 2022 unhandler[2729]: APN Fetch is done.
Tue Jun 21 22:05:53 2022 unhandler[2729]: SMS-Utilities[src/sms_utils.c:161]: count_free_sms s->type: simman
Tue Jun 21 22:06:07 2022 kernel: Changing to SIM2: unable to establish data connection
Tue Jun 21 22:06:27 2022 sim_switch[5808]: [1-1.4] SIM switch in progress. Triggered by data_fail rule

As you can see, the next-to-last line shows that sim2 cannot get data-connection after the fail-over from sim1 back to sim2.
The last line then shows that fail-back to sim1 is triggered...

Thx for help,
BR Rainer

by anonymous
Any news regarding non-working operator-blacklisting?

Thx, Rainer
by anonymous
Blacklisting still does no work :-|

Any news?

Thx, Rainer
by anonymous

Could you please replicate the issue and provide a troubleshoot.

Also, I would like you to post output of the following command from SSH: 

  • gsmctl -y

I might need you to try updating the modem firmware. I will send the instructions based on the previous command.

Best regards,

by anonymous
Hi, I did send you troubleshoot and gsmctl-output 3 weeks ago.
( I did of course also tried newest firmware. )

Any news?

Many thx, Rainer
by anonymous


A couple of suggestions: 

1. Instead of using automatic APN setting, set it manually.

In the WebUI navigate to Network -> Interfaces and edit mobile interface settings. Disable Auto APN and enter it manually.

2 Update modem firmware.

Before attempting the update, you need to connect your router a different WAN source, either wired or wireless. Below are the the instructions:

  • Access your device via SSH and execute the following commands:
    • opkg update
    • opkg install modem_updater
    • opkg install sshfs
    • modem_updater -g
  • The last command will list available firmware versions. Next modify the following command:
    • modem_updater -i <ID> -v <VERSION>
      • <ID> - should be 1-1.4, however, in case of an error you should be shown a correct ID.
      • <VERSION> - enter the latest firmware version from the list of the previously executed command it should be EC25EUGAR08A01M4G.

Best regards,


by anonymous

Many thx.

I did modem-update as you mentioned successfully and I checked after a fresh reboot, but the issue is the same:
Blacklisting Operators does not work at all.

You could simply test by your own with your own operator-id:

a) "gsmctl -f" show for me OperatorNumber "26202" (which is Vodafone in Germany)
b) Under Network->Mobile I create a OperatorList and add this List to SIM2 by Enabling "Blacklisting" under "Operator Settings"
c) After Saving and Rebooting the Router starts with SIM1 (default; Now I do a simple "ubus call sim change" to switch to SIM2
d) After switch I see unfortunately SIM2 is fully working :-|
e) Settings look fine:
    >>> uci show operctl | tail -3

What else can I do?

Best regards,

by anonymous
When enabling blacklisting, you should be prompted with a message at the bottom right of the configuration page: "Your SIM card provider will not be blocked even if blacklisted". Thus, SIM2 fully working is correct behavior, even with its operator blacklisted.
by anonymous

You are so right - I interpreted the popup-message in a bit different way, sorry for this.

So how to test Blacklisting is now working? :

a) I scanned for all operators on my SIM-card and found 26201, 26202 and 2603 (where 26202 is my default after reboot).
b) Then I set operator-selection/scan to "manual" for this SIM and just set 26201, I saw this is working fine on 26201.
c) Then I set a blacklist with just operator 26201 for this SIM and did reboot; but SIM still just uses 26201 properly and ignore the blacklisting, despite 26202 is the default-operator.

Result: Blacklisting cannot be tested since it looks like the router treats the defined 26201 as new default-operator?!?

How could I test now blacklisting is working (which did not worked in 7.02.1 when I travelled between Italy->Swiss->Germany in June).
Many thx, Rainer

by anonymous
Any news?
Many thx, Rainer