FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

11952 questions

14230 answers

22436 comments

35480 members

0 votes
203 views 5 comments
by
Dear all,

I wanted to ask about an issue we are having on Teltonika 955 equipped with a SIM.

The system has worked fine for a couple of days, providing a stable data connection, but after that we see that the router can not establish a stable connection with the mobile data network. In practice, from the logs we notice that router keep continuously disconnected and connected with the mobile data network changing its assigned IP. The connection is highly unstable as the router perform this connection issue within a frequency of seconds, making Teltonika unable to operate it remotely. In some moments of the day, the connection is stable for tens of minutes. The SMS functionality and the Network is always registered as it always responds to the SMS, but the data connection is OFF.

Things we have checked so far:

- All the signal strength indicators are good, confining in "Good" and "Excellent" intervals as defined in the manual. The cell-tower however is close to the deployment point.

- Double-checked the APN and all the parameters of SIM data connection, but seems fine. The SIM has no data limit.

- Forced Teltonika to use 2G, 3G, 4G and automatic selection but nothing happened.

- Performed several reboots of Teltonika but did not help.

If it is needed, I can provide the logs in a private chat.

Can you please advise on this issue?

2 Answers

0 votes
by

Hi,
Same problem.
https://community.teltonika-networks.com/48921/rut955-router-gsm-problem

temporary solution:

in command line
 /etc/init.d/modem stop / disable / enable / restart => works

{gsmctl -D, --shutdown also works as it does shut the modem, modem restarts +- 60 seconds later.}

by

or downgrade firmware to RUT9_R_00.07.01.1_WEBUI.bin

by
Hi Adam, thank you very much!

We have not tried to downgrade the router, it seems the older version has fewer features, and it is not hosted online. However, we also rebooted the router several times but nothing changed. I guess the commands that you used do the same, so for the moment we still have a disconnected connection. Thanks again.
0 votes
by

Hello,

Thank you for contacting us.

I would like you to send me a troubleshoot file. Please, replicate the issue, then access router's WebUI, go to System -> Administration Troubleshoot section and download troubleshoot file from there.

Best regards,

Žygimantas

by
Hi, thank you!

I edited my question and uploaded the tar with the logs as downloaded from teltonika when the problem persisted.

Please keep us updated if possible,

Regards
by

Hello ZygimantasBliu

Have you had a chance to look over the logs? We updated to the latest version, but the problem persists.

Best Regards

by

Hello,

I would like you to try the same SIM in the mobile phone to see if it has a stable connection.

Also, could you try the router with another SIM?

One more thing to try is to enable auto APN option.

The last option is to upgrade your modem's firmware version. Before the upgrade you need to make a backup of your current configuration, in case you wanted to revert back, to save the trouble of reconfiguring the device again. Next, update the router itself to the RUT9_R_00.07.02.1 version with Keep settings option disabled. I assume you have done it already based on your previous comment, but, just in case, the firmware file can be downloaded from here.

Then connect the router to a different WAN source, either wireless or wired, and perform the following steps: 

  • Access your device via SSH (you can use PuTTy client, username - root, password - the same used to access Web interface) and execute the following commands:
    • opkg update
    • opkg install modem_updater
    • opkg install sshfs
    • modem_updater -g
  • The last command will list available firmware versions. Next modify the following command:
    • modem_updater -i <ID> -v <VERSION>
      • <ID> - should be 1-1.4, however, in case of an error you should be shown a correct ID.
      • <VERSION> - enter the latest firmware version from the list of the previously executed command.

Best regards,

Žygimantas