FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
+1 vote
256 views 1 comments
by anonymous

Hi,

I've got an RUT240 running RUT2_R_00.07.02.2 that has one small issue:  In the GUI I can set LTE band selection to "Manual", choose the desired band ("B12"),  and then click "Save & Apply" but that doesn't seem to alter the band configuration on the Quectel modem.  I verified the band setting on the Quectel modem inside the RUT240 with this command in an ssh session:

root@Teltonika-RUT240:~# gsmctl -A AT+QCFG=\"band\"
+QCFG: "band",0x26f,0x80a,0x0
root@Teltonika-RUT240:~# 

The value 0x80a translates to 0x800 + 0x8 + 0x2 where 0x800 is "LTE Band 12", 0x8 is "LTE Band 4", and 0x2 is "LTE Band 2".  That value should be 0x800 (only "LTE Band 12")

Has anyone else encountered this issue where choosing or locking a band in the GUI does not alter the corresponding setting in the Quectel modem?

I tried to manually select the desired band from my ssh session but that command was refused:

root@Teltonika-RUT240:~# gsmctl -A AT+QCFG=\"band\",0,800,0
+CME ERROR: operation not allowed

Thank you in advance,

-Scott

1 Answer

0 votes
by anonymous

Hello,

I would like you to attach a troubleshoot file to your question. Please, replicate the issue, then access router's WebUI, go to System -> Administration > Troubleshoot section and download troubleshoot file from there.

Best regards,

Žygimantas

by anonymous

Hello Žygimantas,

Thank you for your reply. Per your request I performed the following actions:

1) I checked the value for the band setting via SSH:

    root@Teltonika-RUT240:~# gsmctl -A AT+QCFG=\"band\"
    +QCFG: "band",0x26f,0x80a,0x0

2) I checked the band selection in the GUI (please see screenshot with date 2022-07-18 attached to my original message) and hit "Save and Apply".

3) I checked the band selection via SSH again:

    root@Teltonika-RUT240:~# gsmctl -A AT+QCFG=\"band\"
    +QCFG: "band",0x26f,0x80a,0x0
    root@Teltonika-RUT240:~# 

4) I generated the troubleshooting file you requested.  Please find it attached to my original message.

Thank you,

-Scott