10857 questions

12933 answers


25491 members

0 votes
39 views 2 comments
ago by

Hello I have a RUTX11 that I was trying to use with US Mobile (MVNO of Tmobile here in U.S.) 

The speed was very poor so I switched to T-Mobile and got a new Sim card.

The device worked beautifully for about six days, when suddenly connectivity was lost.

When I go to the dashboard under the mobile network status, I see that the carrier is listed as US MOBILE.  I assume this is the problem. Trying to manually select the carrier, scan for operators, or enter the six digit mobile operator code has not worked -- the carrier still says US Mobile with no connection.

I have done a full factory reset of the device, and all firmware both device and modem firmware are fully up-to-date.

Multiple calls to T-Mobile confirm that there is no block on the IMEI or the Sim and everything should be working properly. No one can figure this out!

The question I have for Teltonika or anyone here on the forum is:

Is there some sort of data that gets burned into the modem or locked in some way after using a particular Sim that could cause it to misread the carrier info from the network?

And if that is the case, is there any sort of command to wipe this and fully reset the modem back to a factory state?

ago by

I want to add

  • I have all settings currently at AUTO (APN, Operator etc)
  • RUT Firmware is 7.02.04
  • Modem firmware is EG06ALAR04A01M4G

1 Answer

0 votes
ago by

RUTX11 is currently not certified for T-Mobile in the USA that is why the operator is blocking you as our modem IMEI addresses are not in T-Mobiles database
ago by
What?? This is big news to me. I was told by multiple sales reps that the X11 is certified for T-Mobile. Where are you getting this information? Is there an official document somewhere?