FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
470 views 10 comments
by anonymous

Hello I have a RUTX11 that I was trying to use with US Mobile (MVNO of Tmobile here in U.S.) 

The speed was very poor so I switched to T-Mobile and got a new Sim card.

The device worked beautifully for about six days, when suddenly connectivity was lost.

When I go to the dashboard under the mobile network status, I see that the carrier is listed as US MOBILE.  I assume this is the problem. Trying to manually select the carrier, scan for operators, or enter the six digit mobile operator code has not worked -- the carrier still says US Mobile with no connection.

I have done a full factory reset of the device, and all firmware both device and modem firmware are fully up-to-date.

Multiple calls to T-Mobile confirm that there is no block on the IMEI or the Sim and everything should be working properly. No one can figure this out!

The question I have for Teltonika or anyone here on the forum is:

Is there some sort of data that gets burned into the modem or locked in some way after using a particular Sim that could cause it to misread the carrier info from the network?

And if that is the case, is there any sort of command to wipe this and fully reset the modem back to a factory state?

by anonymous

I want to add

  • I have all settings currently at AUTO (APN, Operator etc)
  • RUT Firmware is 7.02.04
  • Modem firmware is EG06ALAR04A01M4G

2 Answers

0 votes
by anonymous
Hello,

RUTX11 is currently not certified for T-Mobile in the USA that is why the operator is blocking you as our modem IMEI addresses are not in T-Mobiles database
by anonymous
What?? This is big news to me. I was told by multiple sales reps that the X11 is certified for T-Mobile. Where are you getting this information? Is there an official document somewhere?
by anonymous

All of the current certificates available for carries and country/continent can be found here.

If there are any upcoming certificates, we also update that table.

by anonymous

On 27-Sep-2022 the RUTX11 became certified for T-Mobile. Here is the announcement from Teltonika:

https://teltonika-networks.com/about-us/earning-the-t-mobile-certification/

Also T-Mobile advertises the RUTX11 as a device for use with their network on the below page (Devices tab):

https://wholesale.t-mobile.com/iot-solutions/modules-chipsets-devices

Today I tried my T-Mobile data SIM in my RUTX11 and the mobile network status for SIM 1 shows the correct IMEI, card state Inserted, and Operator state changes between Not registered and Denied as I watch the page.

Normally I use a Verizon data SIM and I don’t need to configure anything at all. I can even reset the RUTX11 to default settings and it works fine with the Verizon SIM.

Is there something that I need to enter into the mobile network settings of the RUTX11 for T-Mobile to work? 

Thank you!

by anonymous
Hi,

You would need to use latest FW, I can't really ATM say that there are firmware side requirements for T-Mobile, Verizon does need a lot of stuff to be certified, so I would reccomend trying to upgrade to 7.3.

Also, in the Status > Mobile > Network, what is the connection state shown there?

Maybe you would be able to download a troubleshoot file from System > Administration > Troubleshoot and attach to your comment?

Only Teltonika engineers see attached files for security reasons
by anonymous
Hi PauliusRug,

I do have the latest firmware for RUTX11: RUTX_R_00.07.03 so older firmware issues can be ruled out. Could the modem firmware be an issue? I have never changed that, unless the RUTX11 firmware updates have changed it.

I never had any problems using Verizon since I first acquired the RUTX11. That has always been easy and works great for me.

For the T-Mobile SIM, currently SIM 2, I believe that the Connection State is always Disconnected when I switch to SIM 2. I will be able to confirm this evening. The Operator State changes back and forth between Not registered, and Denied. The RSSI looks very good for my location.

I will also be able to attach a troubleshoot file this evening. Thank you for helping!
by anonymous

By the way, I did try these two APNs for SIM 2 (T-Mobile):

  • fbb.home
  • fast.t-mobile.com
I am not sure what other sorts of settings to try changing.
by anonymous
Hello,

It am not really able to see why the router gets denied, however, I have noticed that it last failed to connect to the 312 250 operator which is Sprint, which seems a bit odd. I would recommend reaching out to the operator about this, they would be able to provide more information on the denied state.

Very low probability is that you get denied due to low signal but I have never heard any operator doing this, just a blind guess
by anonymous

This operator 312 250 makes sense. It is the one shown by the device provided by T-mobile (the device with poor reception and much lower signal strength). It is a Sprint tower. T-mobile coverage in my location is through a partner (Sprint). This is the wording from the T-mobile coverage map:

Coverage is provided by partners in these areas, so speeds and connections may vary.

Do you think that I need to use a different APN for the Sprint tower?

I am unsure how to proceed but it’s encouraging that the RUTX11 modem is attempting to connect to the correct tower – the same tower which the T-mobile provided device uses.

0 votes
by anonymous

Thank you for the link. Very good information to have.

So, is it correct that currently the ONLY Teltonika device certified for use on T-Mobile is the RUT955? I am still getting conflicting info, that the RUTX11 works.