FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
647 views 3 comments
by anonymous

RUT240 running firmware 7.02.4. This also occurred on firmware 7.02.2. When sending the SMS command 'cellular apn=internet', the command is not executed. The SMS is not visible in 'read messages' (as it would be if it was incorrect), but the command is not being executed. I can set the APN in the GUI fine, but cant set it via SMS. Other SMS such as 'status' are working.

I tried this possible solution, but it didnt make any difference:

Please follow these steps in order to solve this issue:
1) Enable auto APN and save the configuration;
2) Wait until device receives some IP address;
3) Disable Auto APN, add custom APN and save configuration.

I also tried setting it via UCI, but the luci-reload command fails (and is seen in the 'read messages' section:

uci set simcard.sim1.apn='yourapn'

uci commit

luci-reload

1 Answer

0 votes
by anonymous
Hello,

You syntax is wrong. I would recommend using cellular SMS command:

admin01 celullar apn=youapn
by anonymous

Hello,

My syntax is correct for the cellular command that I mentioned trying in the post, but your spelling of cellular is wrong. As I said, the cellular SMS command that I tried is not working; it does nothing on the RUT240 that I upgraded to 7.02.4, or on 7.02.2. I have not tried it on a defaulted router; I just dumped 7.02.4 and reverted to 1.14.5 which is reliable.

As for the UCI command; thats a cut and paste from the solution posted by a Teltonika mod, so if its wrong, he's got it wrong. I'm not so familiar with using UCI, and generally just SMS. All I know is his solution didnt work.

Any thoughts mods?

Has anyone else noticed this, or tried it?

by anonymous

yeah, the L's got a bit mixed up.

If you want to use uci commands to set APN, then you would need to write:

uci set network.mob1s1a1.apn='apn'

The simcard config file does not contain the APN configuration, only if auto APN is enabled or not

by anonymous
Thanks for your response, and the info on UCI.

Do you have RUT240's, and have you seen the same issue? It would be useful to know if its just my routers or config.