FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
480 views 4 comments
by anonymous
Morning,
Will try to explain as much as possible what i would like to achieve, which unfortunately is not working at this moment.
Using Firmware version RUT2_R_00.07.02.2.

From network security we need to establish a connection via PEAP protocol, which means username and password.
We would like to achieve the following:
- Setup the Teltonika RUT240 as a router, which will be connected via ethernet cable on a medical device. This ethernet connection is needed because this medical device is not able to setup WiFi connection.
- Setup the Teltonika RUT240 to be able to connect towards out Corporate WiFI network with the PEAP protocol.

At this moment I have setup the Teltonika RUT240 device with assigned IP addres 10.0.0.1 in the General Settings. The medical device will be assigned to IP address 10.0.0.2, which i already did in the LAN configuration section.
Medical device IP Address is 10.0.0.2 with Gateway 10.0.0.1.

The problem is for some reason I cannot create Wireless connection towards our Corporate network. If I go to Network - Wireless I am able to use the Scan option and detect our Corporate Network and see that the Encryption is WPA2 802.1X (CCMP). I click the Join Network option and enter the password I received from our Network team. IN the field name of the network I add the exact name of our Corporate network and click on Submit. The item shows in the list and i can see the status Running. But how can i confirm that indeed this device is connected to our Corporate Network (without asking our Network team obviousbly)? I want to visualize and check for myself that indeed this setup is correct and working.

Adding note, i checked the Scan tool to see if i could find my iPhone hotspot and it has no problems to find the hotspot.

2 Answers

0 votes
by anonymous

Hello, 

It looks like the configuration you made is the correct one and should work. You just need to check which firewall zone you assigned to the corporate network you added. For you to have internet output it should be assigned to the WAN zone. If all this is correct, you can verify if you have internet access by connecting to the router through another ethernet port and try to browse. You can also view the traffic statistics by Status→Real Time Data→Traffic. You should check the configuration of your LAN and medical equipment. I.e. verify that you have RUT240 etc. as default gateway. 

by anonymous
I am trying to make a connection with our Corporate network. Our internal network team has given the RUT240 an static ip address and now i need to connect via the PEAP protocol, which need an username and password. I can only add an username, where is the possibility to conect via the PEAP protocal and choose username / password?

Update:
I have received an static IP Address from our network team which is connected to the WiFi Mac Addres, now I would like to configure this IP addres.
The RUT240 device (via LAN) is now configured as 10.0.0.1, where can I find the option to configure the IP address for the Wireless segment?
Also still looking at the PEAP protocol setup, which would be also helpfull.

The ideal setup would be:
- RUT240 device is connected via LAN cable to the medical device. RUT240 has IP addres 10.0.0.1 and the medical device has 10.0.0.2 as IP Address.
- The RUT240 is connected via WiFi protocol PEAP on our Corporate Network.
by anonymous

we cannot find how to configure the RUT240 to use Wifi as WAN, and route all LAN traffic to wifi.

We want to connect a LAN device through the RUT240 to the Wifi network
in the previous firmware version, we could easily select the Wifi as WAN, and use DHCP on LAN to connect the device. When the zones are configured correctly, RUT240 will route all traffic from local LAN to Wifi.

https://wiki.teltonika-networks.com/view/RUT240_WAN_(legacy_WebUI)

with the new firmware we cannot find this setting:

https://wiki.teltonika-networks.com/view/RUT240_WAN

how can we setup the RUT240 to use wifi as WAN?

we now downgraded the RUT240 and could easily configure Wifi as WAN and now it is working! 

Then we upgraded the firmware again, and now it is not working anymore. We now see that the Wifi is called WWAN (wireless WAN) but we can not assign this interface in the firewall zones.

we will downgrade again to get this working.

0 votes
by anonymous
I am trying to make a connection with our Corporate network. Our internal network team has given the RUT240 an static ip address and now i need to connect via the PEAP protocol, which need an username and password. I can only add an username, where is the possibility to conect via the PEAP protocal and choose username / password?

Update:
I have received an static IP Address from our network team which is connected to the WiFi Mac Addres, now I would like to configure this IP addres.
The RUT240 device (via LAN) is now configured as 10.0.0.1, where can I find the option to configure the IP address for the Wireless segment?
Also still looking at the PEAP protocol setup, which would be also helpfull.

The ideal setup would be:
- RUT240 device is connected via LAN cable to the medical device. RUT240 has IP addres 10.0.0.1 and the medical device has 10.0.0.2 as IP Address.
- The RUT240 is connected via WiFi protocol PEAP on our Corporate Network.
by anonymous
Update from my side again.
We have the PEAP protocol working. We looked at the configuration of the Wireless settings and found the correct protocol. We have a working connection at this moment.
Now we are looking at the forwarding aspect, which we are trying to figure out. Forewarding any to any does not seem to do the trick.

At this moment we do not see the WAN option in the Advanced Menu, is there a reason we do not see the WAN option?
We have the RUT240 connected via Ethernet cable on the LAN port and the RUT240 connected via WiFI on our Corporate Network and we are trying to setup the WAN, but we do not see this interface. Or does this mean we need to establish it first somewhere?

Thanks in advance for any reply.
by anonymous

Hello Support,
I'm trying to help Chris with this subject. ( I have remote access)

We want to connect a LAN device through the RUT240 to the Wifi network
in the previous firmware version, we could easily select the Wifi as WAN, and use DHCP on LAN to connect the device. When the zones are configured correctly, RUT240 will route all traffic from local LAN to Wifi.

https://wiki.teltonika-networks.com/view/RUT240_WAN_(legacy_WebUI)

with the new firmware we cannot find this setting:

https://wiki.teltonika-networks.com/view/RUT240_WAN

how can we setup the RUT240 to use wifi as WAN?

thanks a lot.