FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
226 views 2 comments
by anonymous

Hello together!

I own a RUT955 with firmware RUT9XX_R_00.06.09.2 (probably not the most recent HW version) and I now want to use IPv6 on the device, as for example the OpenVPN server I want to connect to only supports IPv6.

Basically my problem comes down to this, I think:

The OpenVPN client throws the same error "permission denied".

The settings I changed from a fresh vanilla installation:

Enabled IPv6:


Disabled IPv4 only in the Mobile Settings:

my ifconfig looks like there are IPv6 addresses on all neccessary interfaces:

And my /etc/confic/network (unaltered):

config interface 'loopback'

        option ifname 'lo'

        option proto 'static'

        option ipaddr '127.0.0.1'

        option netmask '255.0.0.0'

config interface 'lan'

        option ifname 'eth0 tap0'

        option type 'bridge'

        option proto 'static'

        option ipaddr '192.168.1.1'

        option netmask '255.255.255.0'

        option ip6addr '2001:db80::2/64'

config interface 'wan'

        option proto 'dhcp'

        option ifname 'eth1'

        option enabled '1'

config interface 'wan2'

        option metric '10'

        option ifname 'wwan0'

        option proto 'none'

config interface 'wan3'

        option proto 'dhcp'

        option ifname 'wlan0'

        option enabled '0'

        option disabled '1'

        option metric '20'

config switch

        option name 'switch0'

        option reset '1'

        option enable_vlan '1'

config switch_vlan

        option device 'switch0'

        option vlan '0'

        option vid '0'

        option ports '0 2 3 4'

config interface 'ppp'

        option enabled '1'

        option backup '1'

        option metric '10'

        option cid '1'

        option ifname 'wwan0'

        option proto 'qmi2'

        option service 'auto'

        option device '/dev/cdc-wdm0'

        option pppd_options 'noipdefault'

        option method 'nat'

        option mtu '1500'

        option volte '0'

        option pdptype '1'

        option apn 'internet'

        option auth_mode 'none'

config interface 'ppp_usb'

config interface 'stabridge'

        option enabled '0'

config alias

        option netmask '255.255.255.0'

        option proto 'static'

        option interface 'wan2'

Any ideas on what I have to change in order do get IPv6 through is much appreciated.

Thanks!


Sebastiam

2 Answers

0 votes
by anonymous
Hello,

None of your WAN interfaces have globally routable IPv6 addresses assigned.

Does your mobile plan include IPv6 service?

Maybe it requires a specific APN to use IPv6?

Best regards,
by anonymous

Hey!

Thanks for your reply!

Yes, my data plan allows IPv6. I use a daughter card (shared data) of my normal phone contract.

And my phone is able to connect to the OpenVPN server without any problems and there's no special APN for IPv6 (dualstack).

0 votes
by anonymous
Hey, it's me again.

Are there any other ideas? My provider supports IPv6, I'm sure about that as my phone works with the SIM

Thanks again!
by anonymous
Try setting pdptype to 'ipv4v6' instead of '1', and restart the network. This should assign an ipv6 address to the wan interface.