FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
1,375 views 1 comments
by anonymous
I hope to replace my old 4G modem and my aging router with the RUTX50X. To start with I’d simply like to use the RUTX50 to replace the modem.

I’ve swapped out the old modem, substituting the RUTX50 - from the router’s perspective it looks the same. Problem is that I’m not able to connect to the Open VPN instance that’s running on my router from the open internet. I’ve checked that my public IP address good - it’s a DDNS that’s is currently resolving to the expected IP address.

On my old modem, I had it set to bridge mode towards the router. Is there something I should do with the RUTX50 to achieve the same thing? I haven’t been able to find this in the settings yet and could use some help with this.

Thanks!

(P.S. - At some point I will set up the Open VPN on the RUTX50, but I need to plan to be able to provide the new connection profiles to where they’re needed. )

EDIT: P.P.S - I put the old modem back in front of the router and everything works like before, so at least I know I haven’t broken something else.

1 Answer

0 votes
by anonymous

Hello, 

You might need to turn on "Advanced WebUI" mode first. You can do that by clicking the "Basic" button under "Mode", which is located at the top-right corner of the WebUI.

The NAT/BRIDGE/PASSTHROUGH modes can be found in Network -> Interfaces section by editing your mobile interface's settings, as shown here.

You can find instructions on bridge/passthrough mode configuration here.

As for the OpenVPN, could you explain how did you configure it, or replicate the configuration, then access router's WebUI, go to System -> Administration -> Troubleshoot section and download a troubleshoot file. Attach this file by editing your question. The logs might in the file might provide more details into the issue.

Best regards,

Best answer
by anonymous
I tried using Bridge mode and still didn’t get through to the OpenVPN server running on my router. I also tried Passthrough mode (out of desperation, I suppose?) and that didn’t get me there either.

What did help was something I should have thought of sooner. This was to set the mode back to NAT and then simply forward the port for OpenVPN to the IP of the router that’s running it for the moment. For some reason, I didn’t think that would work, but it did.

I still don‘t really understand what more I needed to do other than switch to Bridge mode, but I’m sure this is just ignorance on my part concerning what else I need to set up for the RUTX50 to be transparent. On the old modem, there weren’t so many settings.