FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
366 views 2 comments
by anonymous
Dear all,

I'm experiencing higher than forecasted data traffic due to RMS being active.

I'm testing a RUT240 unit with firmware RUT2_R_00.07.03.

I have set up RMS to have a dynamic update period of 60 minutes and static update period of 5 days.

The estimated monthly data usage is 153.69KB download and 364.13KB upload, for a combined total of 517.82KB/month.

Nonetheless precisely every 60 seconds, a connection is established to 18.196.62.30 with 0.22KB data exchange. This is visible in the Status > Real Time Data > Connections page

This leads to a data consumption of 9504KB/month, 18 times more than the forecast.

I tried to change the Dynamic monitoring to 120 minutes, but the data consumption is still the same.

I'm about to deploy 40 RUT240 units to the field and we would like to use 5MB/month data plan.

My application uses around 2.5MB/month.

Approx. 915KB/month will be used by Auto Reboot ping every 15 minutes.

That leaves approx. 1.5MB/month for RMS.

Is RMS forecast wrong or is there anything is not working as intended?

If you need to obtain Serial number of the test unit or other personal data, please send private message.

With regards

Nick

1 Answer

0 votes
by anonymous

Hello,

The data estimate is approximate, and shows data measurement tied to exchanges related to monitoring information.

Router's configuration shows that there is a keepalive value configured to maintain connection to RMS status established, and, I assume, that is where additional data consumption every minute comes from:

root@Teltonika-RUT956:~# uci show rms_mqtt
rms_mqtt.rms_mqtt=rms_mqtt
rms_mqtt.rms_mqtt.rms_port='15010'
rms_mqtt.rms_mqtt.ca_file='/etc/rms_mqtt/ca.crt'
rms_mqtt.rms_mqtt.cert_file='/etc/rms_mqtt/client.crt'
rms_mqtt.rms_mqtt.key_file='/etc/rms_mqtt/client.key'
rms_mqtt.rms_mqtt.rms_keepalive='60'
rms_mqtt.rms_mqtt.rms_ip='18.196.62.30'

I would suggest to login to the router via SSH and try modifying this value with a text editor. It can be found in /etc/config/rms_mqtt file.

Best regards,

by anonymous
Thank you for the suggestion, I was able to perform the value change.

However I have noticed the change is lost once the router is rebooted. How can I make it permanent?

Do I need to restart a service after the value change, or is it automatically picked up by the MQTT client?

I may suggest to revise the estimated monthly data usage of RMS by adding this 9504KB/month keep alive traffic, or a revised value if the keep alive parameter is increased in future firmware revisions. This would help picking up the right data plan of the SIM cards.

With regards,

Nick
by anonymous

Hello,

Indeed value seems to be reset after each reboot. Try the following workaround:

Login to the WebUI and try adding the following lines in System -> Custom scripts page, alternatively, they can be added via SSH in /etc/rc.local file:

  • sleep 45
  • uci set rms_mqtt.rms_mqtt.rms_keepalive='<value>'
  • uci commit

45 argument of sleep command was enough to replace keepalive value for several reboots in a row, though I suggest to do some testing, as you may need to increase it.

Best regards,