FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
394 views 8 comments
by anonymous
Hello

I have a RUTX11 running fw RUTX_R_00.07.03.4

The Ethernet (Eth1) interface from the cable ISP provides working IPv6 via DHCP6. I also have IPv6 enabled on the mob1s1a1 LTE interface and that works as well. I can ping both ULAs aka "public IPs" and they work. The problem is, I cannot figure out how to indicate the preferred routing order / failover order for these interfaces. The main reason for this is to avoid heavy data charges due to traffic choosing to exit via the LTE interface even though the primary WAN is up and running, simply because that route got preferenced by the system routing table.

I want the order to follow the IPv4 settings as specified in Network → Failover but that seems to be V4-only. Is this possible? How can it be done?
by anonymous

____________

1 Answer

0 votes
by anonymous

Hello,

  

This should be possible by simply changing the metric of the interface in the Network → Interfaces → General menu. By default, wired WAN will have a higher priority, so it should already be used as the main WAN connection. However, to change the priority, simply hold and drag the arrow symbol on the top left corner of the interface:

This way wired WAN will be used as a default gateway, and a mobile connection will only be used if the desired address is unreachable via the main WAN/wired WAN gets disconnected, etc.

Please keep in mind, that the LTE interface will still be active, even when the wired WAN is connected.

Also, make sure Load Balancing is disabled.

  

Best regards,
DaumantasG

by anonymous

Thank you - I tried what you said to move the wan6 above the mob1s1a1 interface so it would have a lower metric (I confirmed it in the GUI) but it didn't seem to work. IPv6 traffic is still exiting by default via the LTE interface. I checked with:   curl -s 6.ipquail.com/ip 

by anonymous

Also, I found this post https://community.teltonika-networks.com/56579/rutx11-failover-with-wwan-and-wifi-with-ipv6-not-working which says that IPv6 failover will not be available until firmware 7.5 (not sure if this is still correct).

by anonymous

Hello,

  

Indeed, the MWAN3 package (failover) will be updated with the IPv6 support in the v7.5 release (at least this is the goal at the moment).

As for the interface metric, could you navigate to the wan6 interface, open its advanced settings, and change the gateway metric to 0? The mobile interface should have a gateway metric of 2 by default.

Let me know if this helps!

Best regards,
DaumantasG

by anonymous

@DaumantasG thank you again. I've run into a new problem now, when trying to follow your guidance. I had disabled IPv6 on this unit because of the original problem. I followed the steps from here.  Now, even after "undoing" that, I can't get the unit to pull a DHCPv6 anymore. I ran a tcpdump and I see the RA packet and the prefix being handed over to the RUT but something is not set correctly because wan6 never gets an IP. 

by anonymous

@DaumantasG I finally (after many hours) solved the DHCPv6 problem (the solution was found here, btw—which was to remove the Source IP address: fc00::/6 restriction from the Allow-DHCPv6 Firewall rule!)

I tried to set the wan6 interface metric to 0 as you suggested, but LuCI popped up an error saying it must be at least 1. So I picked 1.

This is how my interfaces look now:

https://cln.sh/QWv7MTk1 (screenshot)

Unfortunately, even though the wan6 has a lower metric than mob1s1a1, it is still routing traffic out via the mob1 interface...

Any other ideas?

by anonymous
Hello,

As this issue requires some further investigation, I'd like you to replicate the issue and generate a troubleshoot file by navigating to System → Administration → Troubleshoot. This file can be attached to your original post and will only be visible to Teltonika moderators.

Thank you!

  

Best regards,
DaumantasG
by anonymous

@DaumantasG Thank you. It has been a very busy few weeks and I've gotten pulled onto some other projects. Now also RUT OS 7.4 was released, so I will need to revisit this a little later and see if anything has changed.