subscribe to our Youtube


14256 questions

16893 answers


54556 members

0 votes
248 views 4 comments
Dear all,

since this maintainance, that went wrong (but the problem may not be related to this, but I can't know now, as before the maintainance that you did, VPN hub here was working)... I have a RUTX11 where I configured VPN hub. The problem is that sometimes, when I enter the IP address to access the device, it works, sometimes I have to wait a few minutes and most of the times, we can't access the device at all.

But when trying to access the same device via the functionality "Remote Access" it always works fine.

I have tried also using the 3 different locations provided (US-Virginia, Germany, Bahrain) but all with the same results. I have also tried to start the VPN server and even restart the modem, before establishing the VPN connection via OpenVPN, but again with the same results.

Do you have a recommendation. Open VPN is used on a windows and mac machine.

Thanks in advance for your feedback.

best regards

1 Answer

0 votes


Could you open the .ovpn configuration file with a text editor and modify it by adding an additional option to set MTU value:

  • tun-mtu

The values to try are:

  • 1380
  • 1360

The file could be edited in a following way:

Best regards,


it's a while since you replied, but I did try but still not working...

just to summarize. I have 2 RUT241.

The first RUT241 connected via Internet provider A (4G) has no problem to create VPN hub and I am able to create successfull VPN connection (with OpenVPN but even also using the new beta Teltonika VPN client).

The secnd RUT241 es connected via Internet provider B (WAN << ADSL connection with 4G as failover): I have created a VPN hub, then I start the VPN connection using OpenVPN client or also the new beta Teltonika VPN client. But it is not working, as no access is established.

I am attaching the trouble shoot file, if you can have a look and advice. Thanks in advance !!!

The troubleshoot file indicates that local='link-mtu 1541', remote='link-mtu 1542', which means that the suggested values were not added. Changing MTU has helped to resolve a similar issue here.

Also, the file indicates that "Initialization Sequence Completed", meaning that VPN connection did establish.

Since you have two WAN sources, could you check if the issue is not WAN related. First, in Network -> Failover page edit settings for both WANs by adding the following for ADSL and LTE connections:

Switch to LTE as your Main WAN and see if the device is accessible through a tunnel established over mobile connectivity?

Best regards, 

Dear  ZygimantasBliu,

I have added now the line "tun-mtu 1360" or "tun-mtu 1380". Also I have updated the flush connections as suggested above. So far, it did not work: we are not able to access the device via VPN.

As the router is remote and we can't reach it physically very easy at the moment, before doing the 'experiment' of switching LTE as main WAN, I would like to ask the following question regarding failover, as the manual is not very well written in this area (it good to list all properties etc but does not explain business):

1. Assuming in Network >> Failover, we have 2 entries  with the following order:

- wan (type wired, Status online, activated ON)
- mob1s1a1 (type mobile, status online, activated ON)

2. Further below within the same screen, there is the "Rules section", and there is only one entry "default_rule" and the column "use policy" indicates "default(failover)". If you click on Edit, the new modal windows "Rule configuration", in second section "POLICY", under mode "Failover", the member used is currently selected "wan" and next line/entry 'mob1s1a1".
My question: What happens if I select here instead the following order "mob1s1a1" and 2nd line/entry "wan".
And the same time in previous interface main screen (Network >> Failover), as described above, we will have the entry "wan" appears first and "mob1s1a1" is second.

What will be the behaviour?

Thanks in advance.

PS: (attached screenshot of the screen Network >> Failover)
Apologies for late reply.

Regarding failover behavior, traffic routing follow interface order in the main failover page, unless other rules with more specific source/destination IPs/ports are configured with separate interface order.

As for your VPN hub, is the issue still relevant?

I have reviewed your HUB configuration, it appears to be correct. Considering that the HUB was working previously without issue, the only other suggestion I can offer is to update firmware to the latest 7.04.2.

Otherwise, I could consult RMS team, but their reply will most likely begin with the same suggestion. Thus, if possible, I would like to get that out of the way.

Best regards,