subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
177 views 4 comments
by anonymous

I have 3 RUT955's but one of them will not reconnect to RMS it used to work but now cannot connect anymore.

Credit activated, RMS enabled on router but continues to show "connecting"

Connection state Connecting

1 Answer

0 votes
by anonymous


A couple of other things you can try:

  • Reboot the device;
  • Reset your device to factory default settings (in router's WebUI go to System -> Backup -> Restore default settings).
  • If possible, try reinitiating connection to RMS by sending SMS to the device with the following syntax:
    • <router_password> rms_connect
      • Replace <router_password> with the password used to login to router's WebUI.
  • If not currently installed, update your device to the latest firmware version (can be downloaded from here).
  • Login to the device via SSH and execute the following command:
    • /etc/init.d/rms_mqtt restart 
  • Lastly, could you unregister the device from router's WebUI Services -> Cloud solutions -> RMS and re-add it again?

Otherwise, could you provided a serial number of your router?

Best regards,

by anonymous
Thankyou for your assistance.

I have tried all of your suggestions without any luck.

I also tried to telnet from the device to the rms server as suggested in other posts. telnet worked ok.

serial number for the device is: 1122220673
by anonymous

The system shows that the device did not try to connect to RMS at all, since it has been added.

Could you login to router's WebUI, navigate to Services -> Cloud solutions -> RMS and press Connect several times.

Otherwise, I would like you to attach a troubleshoot file to your question. Please, replicate the issue, then access router's WebUI, go to System -> Administration -> Troubleshoot section and download troubleshoot file from there. The logs in the file might provide more insight into the issue.

Best regards,

by anonymous
The connect button is not available when RMS is enabled. When disabled, the UI says it needs to be enabled to connect (impossible logic).

When enabled there is an unregister button. I have tried this many times.

I have sent a private mesaage with the troubleshoot file. Can you check from the server end what is happening?
by anonymous
As mentioned, server side only shows that the device did not try to connect to RMS, thus not further details are available from there.

However, there are errors in your device logs, indicating issues with memory card storage, where RMS process tries to access some memory addresses, but fails. There is a possibility of SD card corruption

Could you disable storage expansion, reset the device to factory defaults and try connecting to RMS again?

Best regards,