FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
356 views 0 comments
by anonymous

The CLI option in the GUI of routers is not accessible if SSL (https) is turned on, giving the following error message: "To access CLI you need to add certificate acception to your browser!"

There has been given the bad work-around advice to turn off https access of the GUI so to be able to use the GUI CLI, which cannot be regarded a serious advice, concerning networking security. Also some advice to fiddle around with own certificates in the browser.

I suggest that the best is to just fix this bug please and make the CLI accessible in the GUI without compromising security and without having to fiddle around with SSL certificates on any client machine that wants to use it.

This issue is not new, it has been discussed in the past here:

  1. GUI CLI says "To access CLI you need to add certificate acception to your browser!"
  2. Using CLI through Web UI SSL (https) won't work, security

1 Answer

0 votes
by anonymous
Hello,

Thank you pointing this issue.

The developers are aware about it. The solution is being worked on. Currently the it is set to be included in 7.5 firmware release, though at this point this is an estimate only and might be pushed to further releases.

Best regards,