FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
+1 vote
239 views 1 comments
by anonymous
Regarding the connectors is it possible to use the X50 with only 1 pair of antennas?

Is it required to us a 4x4 Mimo Antenna? We have it installed with one 2x2 Mimo Antenna and the 5G Band is working pretty poor. It would be awesome to have the connectors labled like suggested (eg. A-B/C-D) to clearly indicate whats needed. Or something like "If you intend to use 4G Band, Connector A or B need to be connected"

Best Theo

3 Answers

0 votes
by anonymous
Best answer
0 votes
by anonymous
Hello,
I ask myself the same question.
Do the antennas work in pairs for each SIM or all 4 together ?
by anonymous
Coming from the RUT240 and RUT950/955 it seems different. The older models did have discrete antennas for each modem. With this unit it seems like one modem with 2 Sim cards and just one quad antenna!? I hope we will be enlightened.
0 votes
by anonymous
Hello,

  

Indeed, the linked forum article describes the behavior of the RUTX50/TRB500 antennas the best.

They are all recommended by the modem manufacturer, thus there are no AUX antennas. However, when deployed in an LTE-only environment, ANT0, and ANT1 will make a bigger difference.

Hope this answers your question!

  

Best regards,
DaumantasG