FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
976 views 18 comments
by anonymous
After i updated my rut241 to firmware 00.07.04.2 i have problems with google on my android phone, tablet and tv.

My 4g connection is fine and i have no problem with things that are not related to google, like my security camera.

Gmail or YouTube doesn't work or other apps from googleplay.

For example, when i open the Netflixapp there is an errorcode that says internet is connected but no connection to Netflixserver. Same if i try to search for phoneupdates, no connection to server.

I have tried to go back to older firmware. With 00.07.04.1 it's the same problem.

With 00.07.03.4 it works fine again.

But i want to solve this problem and be able to upgrade to the latest firmware.

My knowledge of these things are at minimum. Is there maybe something in the firewall in the newest firmware that are blocking googleservers??

1 Answer

0 votes
by anonymous

Hello,

Could you confirm whether you are currently using a mobile connection? If so, please navigate to the Network -> Interfaces and then edit the Mob1s1a1 interface. Within the advanced settings tab, try lowering the MTU to either 1400 or 1440.

Additionally, please check if software flow offloading is disabled/enabled in the Network -> Firewall.

If the issue persists, please provide two troubleshoot files. Generate the first file when the connection is functioning correctly on version 7.03.4. Then, generate the second troubleshoot file from version 7.04.2, specifically when the issue occurs. Then, attach both files by editing your question. The attached files will only be visible to Teltonika moderators.

Kind Regards,

Andzej

by anonymous
Hi

I'm starting to suspect that there is something wrong with my tablet.

After some investigation on Internet it seems like there's more people than me having problems. For example tablet working fine with hotspot from the phone but not a router.

If the tablets wifi is broken it must be very bad luck, because if that is the case it's the second tablet with wifi problems for me, that's why it thought it was a router problem.

So now I'm going to return the tablet for service and hope the problems are over.

Thank you for the help, and you did solve the "Googleproblem" (the MTU)
by anonymous

Hi,

Not sure, but it may be the tablet as there is not much in the logs.

I would, however, suggest experimenting with different WiFi settings on the RUT to see if it helps to improve the situation. Specifically, you can try adjusting general WiFi settings such as channels, width, disabling legacy rates, etc. You can find more detailed information about these options here.

Kind Regards,

Andzej

by anonymous
Hi I'm back.

Still having the same problem, sometimes issue occurs wifi connected but no Internet.

Tablet has been for service twice and they can't find anything wrong, it works perfect in their network.

I have been experimenting with different settings in both the router and the tablet, and still haven't solve the issue.

The problem is that I don't know if the issue is in the tablet or router. Because other devices connected to the router is working perfect. Only when the tablet is connected at the same time as other devices and the issue occur the other devices also disconnect all at the same time.

But the tablet works perfect in other networks. This makes me crazy.

Also there is no consistency when the problem occurs, sometimes there's no issues for hours, and the next day it isn't working even a minute.

Also sometimes it reconnect automatically, sometimes the tablet can't find the network after switching wifi off/on after issue occurred and I have to reboot router, sometimes tablet can se network again but not connect because of authentication problem and I have to reboot router.

Any ideas what to do??!!
by anonymous

Hello,

Could you try to increase the 'DTIM Interval' value, for example, to 10 in the WiFi settings? This change can be beneficial if the tablet goes into sleep mode or if it misses some multicast/broadcast messages.

Additionally, you can try increasing the 'station inactivity limit' to a higher value, like 900. This will help prevent the device from disconnecting too quickly when it's inactive for a longer period. With a higher inactivity limit, the device will stay connected for a longer time without any interruptions.

Also, have you tried to enable 'Disable inactivity polling' and disable 'Disassociate On Low Acknowledgement' in WiFi configurations?

Kind Regards,

by anonymous
Hi and thank you for all the help, really appreciate it.

I have already tried all these settings but DTIM interval, will try that when I get back my tablet.

Because I talked to the tablet dealership today again. They are very helpful, and really want to solve this. They also think that this issue is really mysterious, because other devices works fine. To be 100% sure there's no problems with the tablet we decided to send it to another service shop.

So I'm getting back my tablet probably next week.