FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
252 views 0 comments
by anonymous
Purchased a brand new RUTX09; the Manual feature set wasn't matching the buttons I was seeing in the GUI and noticed the firmware was 4 years out of date. The installed firmware was RUTX_R_00.02.06.1.

I upgraded to RUTX_R_00.07.04.2_WEBUI.bin. When I logged in, I got message "Failed to load menu data".

For all other firmware changes, I had to use the sysupgrade command line program. I tried RUTX_R_00.07.04.3_WEBUI.bin and got the same message.

I progressively downgraded through the below. At some point, I stopped getting an HTML-based error message and just got a javascript error in the browner console. The MD5 sum for every bin file was checked before running sysupgrade.

RUTX_R_00.07.02.7_WEBUI.bin

RUTX_R_00.07.02.6_WEBUI.bin

RUTX_R_00.07.02.5_WEBUI.bin

RUTX_R_00.07.02.2_WEBUI.bin

I then went to downgrade to RUTX_R_00.02.06.1_WEBUI.bin. After running sysupgrade on it, the router was bricked. I had to factory reset via the physical button.

It looks like this is a recurring problem? https://community.teltonika-networks.com/57945/rut-955-failed-to-load-menu-data

Is there anyway to get a functional install of the latest WebUI ?

1 Answer

0 votes
by anonymous

Hello,

  

I will ask you to try and update the firmware using the bootloader procedure described here.

If this does not help, I will ask you to generate a troubleshoot file. This can be done by navigating to System → Administration → Troubleshoot. It can be attached to the original post and will only be visible to Teltonika moderators.

  

Best regards,
DaumantasG