FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
+2 votes
3,210 views 19 comments
by
Hello, community members.

I'm experiencing a problem with my RUT950 when trying to use it in either bridge mode and/or passthrough, since upgrading to the latest firmware. I'm aware that there are some other members who are also experiencing a similar issue with recent firmwares; however, my issue and configuration is not exactly the same.

My RUT950 has always been configured in bridge mode and it has never had any problems. I upgraded from version 4.04 (if I am recalling correctly) to version 6.04.

Whenever installing updates for the RUT950, I always select the checkbox to clear the settings, and then manually reconfigure the settings. Normally, I would just change the mobile connection mode to bridge and my firewall (Sophos XG – running SFOS 17.5.7 MR-7) would have no problems communicating. Note that the interface on my firewall is static (because my ISP gives me a static IP address). After upgrading to the new firmware and applying the required settings (APN, bridge, CHAP authentication), it became apparent that there was a problem. No data would flow from my firewall through to the ISP.

To troubleshoot, I tried connecting the RUT950 directly to a PC while in bridge mode. It was observed that the NIC on the PC would obtain the correct IP address from the ISP, but no traffic would flow. Note that adding the correct IP alias to the NIC would allow access to the RUT950’s web management page. The same behaviour was seen when the RUT950 was connected to my firewall. I also tried using passthrough, which made no difference.

Changing the mobile connection mode to NAT did work, but that configuration is not desirable.

I attempted to downgrade the firmware of the RUT950 to find which version bridge mode stopped working. Bridge mode works for me up to version 5.01.8, but not for versions after (5.02 and above).

Can anyone share some insight into this problem, or perhaps a possible fix so that I can apply the latest firmware?

1 Answer

–1 vote
by anonymous
Hello,

Update routers firmware to the latest one try not to keep settings when flashing, after firmware update try configuring bridge mode on RUT950 (enter PC NIC MAC address) and wait for PC to get and IP address from your ISP when it does try setting DNS servers on your NIC (network interface card) for exmaple try using google DNS (8.8.8.8 and 8.8.4.4) and see if you will be able to ping/access internet from PC.

If PC will still would not have internet access eventhough it has received an IP address from ISP - download troubleshoot file from RUT950 and send it to me (PM).
by anonymous

Hello,

Who has RUT950 with Huawei LTE module, can you plesae using this TEST FW? And if you have some feedback or issue will persist, please download troubleshoot file and PM it to me.

FW: https://community.teltonika-networks.com/?qa=blob&qa_blobid=11015103794905419814

by anonymous

Hello,

Attaching TEST FW for Huawei bridge mode, please test it and provide me the feedabck.

FW: https://we.tl/t-U32G0JB8Yz

Thank you.

by anonymous
Hi, Vytautas. I've tested the firmware that you provided, but unfortunately, was not able to get it to work in bridge mode. I will send the troubleshoot file through to you. For now, I've reverted the RUT955 back to version 5.1.8 (which as mentioned, does work).
by anonymous
Hello,

Thank you for provided troubleshoot file. From it I can see that DHCP for LAN is disabled and this could be the issue why bridge mode is not working.
Just to notice, I try bridge mode on my RUT955 with Huawei module (firmware are the same for RUT9xx series device) and bridge mode is working just fine.

Could you please try following steps:

1. Reset device to default settings;
2. After reset disable multiwan in Network -> WAN section and leave only mobile WAN;
3. Navigate to Network -> Mobile and configure Brigde mode, after saving, wait couple of minutes and end device should get an IP from ISP.

Please make only these changes and see if your PC/end device will receive IP from ISP, if not - try rebooting router and wait for a couple of minutes (~5min).

Let me know.
by anonymous
So I have tried your recommendation, but it still does not work. Typically, I disable the DHCP option because the end device is configured with a static IP address. I changed the end device to use DHCP (temporarily) and it did receive the correct IP address, but still no traffic would flow through to the ISP. I rebooted it, but still nothing.

Just to make sure, I reinstalled the test firmware again and made the same configuration changes, but I can't get it working.

After first boot from the test firmware, the modem does not work (modem mode is NAT and only changed APN and CHAP authentication). On the network status page, it says the Operator State is 'timeout.' If I reboot it, then the modem starts working in NAT mode (I can see the IP address in the RUT955 WAN interface). Then, I switched it to bridge mode; the end device can communicate with the ISP for about five seconds, then it stops working.

I will send you a new troubleshoot file.