FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
1,211 views 4 comments
by

Hello, is possible to configure RUTX10 with tagged VLAN on WAN interface? ISP requires PPPoE protocol with login/passwd + Tagged VLAN ID: 848. I already tried to setup via SSH as mentioned in this post.

The goal is to achieve internet connection. ISP: 365internet

What am I missing? 

2 Answers

0 votes
by anonymous
Hello,

It would be nice if you include your ISP and Service you're trying to achieve in the question, because such VLAN configurations may differ every time. But here's some default configuration that you could try:

You will have to go to your VLAN configuration and add 848 ID VLAN that is tagged to your WAN interface. Everything else should be off if I correctly understand your ISP requirements that only WAN interface should be tagged.

Once you've done it you need to go to your Interfaces and edit WAN interfaces to work by PPPoE protocol, then you will be able to write down username and password in the fields given below.

After that, your configuration should be done.
by

Hello, I flashed latest firmware and reset settings to factory default. In the first step i set VLAN ID 848 to WAN port and then confgured WAN interface to PPPoE with login+pwd. 

Unfortunately there was no connection on WAN interface at all. So after several bad words I tried to create wan2 interface again with the same pppoe configuration but with interface eth1.848 assigned. And yes, WAN got an IP address from ISP and seems to work. But there is still something missing because LAN/WLAN clients still have no access to the internet.

What is the purpouse of default VLANs (1 and 2)? They are set to [Off, Off, Off, Untagged] and [Untagged, Untagged, Untagged, Off]. I tried to configure my VLAN 848 as [Off, Off, Off, Tagged] and [Tagged, Tagged, Tagged, Tagged]. If there is not "Tagged" on Wan port set, wan2 interface is not connected (does not receive address from ISP).

Just for information, with another router everything works well. There is a screenshot of the configuration. 

Thank you for any hints.

by anonymous

Hi, try this:

  1. When creating VLAN ID 848, select wan port as tagged, and preferred LANs untagged, but keep in mind that these LANs then should be OFF in VLAN ID 1.
  2. Create a new interface called something like PPP, choose PPPoE as your protocol, enter your PPPoE credentials.
  3. Go to physical settings and select eth1.848 (wan) as your interface.
  4. In firewall settings choose WAN.
  5. Go to the LAN interface and in the physical settings, add eth0.848 to current selections of interfaces.
Come back to me with the results.
EB.
by
Hello Ernestas,

yes! My internet finally works with RUTX10! Thank you a lot for simple instructions.

I will share couple notes I get from this for someone else facing similar issues:

1. Always start with creating/managing VLANs. It will create interfaces eth0.xxx and eth1.xxx (x = tag ID) automatically.

2. Setting VLAN1 to off for physical ports LAN1, LAN2... will make the router unreachable from this ports. (Router administration web interface still can be accessed via WLAN).
by anonymous
Hi,

glad you managed to take care of this issue and the suggestions will be really helpful for those who will face the same issue in the future.

EB.
0 votes
by anonymous

Hello,

I'm not sure if this is happening with your RUTX10 so I thought I would share. Recently I've had major issues with LAN bridging to WAN. I was running your config on my RUTX10 for a while with VLAN ID 10 for my ISP and WAN Physical settings set to 'eth1.10' and LAN Physical settings set to 'eth0.10'. VLAN Settings ID = 10, LAN Port 1,2 & 3 = 'Untagged', WAN = 'Tagged'. Then recently my devices (iOS and IoT) on my network started having trouble with IPs not being issued, I can't recall if it was after a Firmware upgrade or not. I'm running Firmware RUTX_R_00.07.04.2

 Some of my devices would end up getting CG-NAT IPs 100.64.xxx.xxx

Pretty sure I've fixed the issue though now, No more LAN on the WAN port. So far all IP addresses are Issued straight away and in the LAN IP Pool. 

  1. Factory Reset the RUTX10, Change Mode From Basic -> Advanced (top Right)
  2. Network > VLAN > Add > WAN port = 'Tagged' >VLAN ID Set = 10. (I also SET the VLAN ID 1 & 2 WAN ports to 'Off'). Leave VLAN ID 1 - LAN1, LAN2 & LAN3 as 'Untagged' > Save and Apply.
  3. Network > Interface > General > WAN > PHYSICAL SETTING > Interface  change to 'eth1.10' > save and apply.
  4. That's It, I left all the Interface LAN settings as ‘Default’ i.e Physical Setting > Bridge Interface = Set to ‘On’  and Interface = Set ‘eth0’.

Kind Regards

Adam