FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
1,601 views 27 comments
by anonymous

Hi,

I have TRB140003000 and I upgraded the FW to TRB1400_R_00.01.03 because this version matches the profile I am using. An error occurred while uploading FW. I have access to most of the settings via WEBGUI but I cannot access the UPGRADE FW menu and I cannot change the system.

 I tried to use the RUT method and upload the system via WinSCP and CLI but I get the message: sysupgrade is not working.

I tried to run TRB from uboot.html / index.html but that doesn't work either.

Am I doing something wrong? Is there any other method?

Regards

2 Answers

0 votes
by anonymous
Hello,

Regarding your issue could you try doing this steps:
 

https://forum.xda-developers.com/showthread.php?t=2588979 -> Install this first

1.Turn off/unplug TRB14x;
2.Press and hold reset button, at the same time plug the power cable and keep holding reset button for about 5 seconds (mobile signal LED's should start blinking);
3.Use cd command to navigate to the place where you saved the tlt-rootfs-trb1400.ubi file (Example: cd C:\Users\ma.ju\AppData\Local\Temp);
4.Then use this command: fastboot flash rootfs_a tlt-rootfs-trb1400.ubi
5. When it completes the process use this command; fastboot flash rootfs_b build/tlt-rootfs-trb1400.ubi
6.Then use this command: fastboot flash boot_a tlt-boot-trb1400.img
7. When it completes the process use this command; fastboot flash boot_a tlt-boot-trb1400.img
8. When it is done unplug and plug your device again, it should boot up as normal
9. Install the latest software through WebUI.

UBI files can be downloaded from here: https://we.tl/t-hHJdVuG2OU

Hope it helps.

Regards,
Jerome
by anonymous
by anonymous

Jerome,

Can you please upload the files again? The file from mega.nz isn't available anymore.

Thank you,

Frank

by anonymous

Hi, 

For the UBI links for TRB140 here are the links: 

https://mega.nz/folder/3gMVlSzS#R_Cu6_F5lSqOQgU8bzYNYw -> TRB1400
https://mega.nz/folder/qplVCC7R#2Lb7B0uOWB4FCy6ShcpQ4Q -> TRB1401

Note: This ubi files will make your device run on 1.06 firmware. You need to upgrade to the latest one using this steps: TRB140 Legacy FW Upgrade Instructions - Teltonika Networks Wiki (teltonika-networks.com)

Regards,
Mellow

by anonymous

Hi Jerome,

thank you for this files. I think I need the Kernel.bin and Legacy.bin to get the TRB alive again.

Can you please upload:

- openwrt-mdm9x07-trb1400-squashfs-legacy.bin
-  trb1400-kernel.bin

Thank you,

Frank

by anonymous
Hello,

Kindly check this link for the said files: https://mega.nz/folder/LxN0yJ6Y#wZAd9DcrDsJtxPAKBkqGMA

Kind Regards,
Mellow
0 votes
by anonymous

Hello, 

I will reupdate this thread  with the steps for TRB recovery and live links: 
---------------------------------------------------------------------------------------------------------------------
Recovery using UBI Files: 

https://forum.xda-developers.com/showthread.php?t=2588979 -> Install this first

1.Turn off/unplug TRB14x;
2.Press and hold the reset button, at the same time plug the power cable and keep holding reset button for about 5 seconds (mobile signal LED's should start blinking);
3.Use cd command to navigate to the place where you saved the tlt-rootfs-trb1400.ubi file (Example: cd C:\Users\ma.ju\AppData\Local\Temp);
4.Then use this command: fastboot flash rootfs_a tlt-rootfs-trb1400.ubi
5. When it completes the process use this command; fastboot flash rootfs_b build/tlt-rootfs-trb1400.ubi
6.Then use this command: fastboot flash boot_a tlt-boot-trb1400.img
7. When it completes the process use this command; fastboot flash boot_b tlt-boot-trb1400.img
8. When it is done unplug and plug your device again, it should boot up as normal
9. Install the latest software through WebUI.

TRB UBI Files: https://mega.nz/folder/KhEExbAL#Fpt9TWIpMj2V5Nlp5XL_lQ
---------------------------------------------------------------------------------------------------------------------
Recovery using BIN files: 

https://forum.xda-developers.com/showthread.php?t=2588979 -> Install this first

1.Turn off/unplug TRB14x;
2.Press and hold reset button, at the same time plug the power cable and keep holding reset button for about 5 seconds (mobile signal LED's should start blinking);
3.Use cd command to navigate to the place where you saved the tlt-rootfs-trb1400.ubi file (Example: cd C:\Users\ma.ju\AppData\Local\Temp);
4.Then use this command: fastboot flash rootfs_a openwrt-mdm9x07-trb1400-squashfs-legacy.bin
5. When it completes the process use this command; fastboot flash rootfs_b openwrt-mdm9x07-trb1400-squashfs-legacy.bin
6.Then use this command: fastboot flash boot_a trb1400-kernel.bin
7. When it completes the process use this command; fastboot flash boot_b trb1400-kernel.bin
8. When it is done unplug and plug your device again, it should boot up as normal
9. Install the latest software through WebUI.

TRB BIN Files: https://mega.nz/folder/LxN0yJ6Y#wZAd9DcrDsJtxPAKBkqGMA
---------------------------------------------------------------------------------------------------------------------

I hope it helps :) 

Kind Regards,
Mellow

by anonymous
Thanks Mellow for your help,

I just tried the Recovery using BIN files, after following the instructions i cant reach the Device with the IP 192.168.2.1

Do you have any suggestions why?
by anonymous

Hello, 

Kindly do the reflashing I made a small mistake about the step-by-step instruction you need to do a flash boot in rootfs_a, rootfs_b, boot_a, and boot_b. Let me know if you are still encountering the error. 

Regards,
Mellow

by anonymous

Hello Mellow,

"Recovery using BIN files" works for me.

Thank you.

Best regards,

Frank