10444 questions

12453 answers

19377 comments

21853 members

+1 vote
433 views 33 comments
by
I have the RUTX11 set to use the 4G / LTE SIM for Fail-Over only but in the last 3 weeks its using 100 MB (50 up and 50 down)?

I replaced an RUT950 with this RUTX11 and never saw the 950 use any data... how to I fix this on the X11?

thx!
by

Same result. As soon as I turned on Failover it started doing pings and using data. If you're engineers can't remote in to debug this and fix it the send me a new unit and lets see if you have a defect in your hardware

If all the settings are correct and your engineers cant figure this out then send me a new unit and I'll test it.

I've spent a TON of my time and I cant use this device as it was designed. Clearly there is a major bug with 4G Failover there is not with 3G.

by
Hi,

Kindly share with me your Anydesk ID in these said timings. Dubai Time around 3:00PM-4:00PM (GST)

Regards,
Mellow
by
@mellow - Sent you a private message to discuss remote access
by
Kindly check my response

Thanks

Regards,
Mellow
by
Hi what was your fix for this as i  just think i got over a wifi issue but then noticed a few kb flowing through rx/tx in the interface tab for the sim card slot when not in failover to the sim? I thought the solution was in the advanced tab for the sim where i switched off "bring up on boot" thinking from the terminology used for bring up on boot it would mean on reboot the init would keep the sim powered but do nothing with the data until the failover kicked in . This didnt seen to be the case in rx/tx status a few kb of data was still seen flowing on reboot.

Now that wouldnt be a big issue with my current test sim as its totally unlimited .And some providers will actually switch off sim  / not roll over data etc  is unused for few months , forcing you to use pings . However for the final deployment of the router i may have to use a pay as you go sim with non of those terms  ,i.e in total reserve i.e nothing used from data until required or i decide to ping the sim manually . Im running the latest firmware on both os and modem so i dont believe that in itself will be the fix , Can you please share your fix . Thanks

3 Answers

0 votes
by
Fix = factory reset and flash back to Firmware RUTX_R_00.02.05.2

... since doing that its been working perfectly for months.  Recent firmware releases have ton of bugs which many people have documented (4G usage, UI freezing, setting not saved, etc)
Best answer
0 votes
by

Hello, 

For the failover issue you are having with RUTX11 could you try configuring the flush connection settings? You can do it by navigating to Network > Failover edit the rules of mobile and wan.



So that where there is a failover happening all the devices that is currently connected will be also refreshed.

Kindly let me know the results

Regards,
Mellow

by

to be clear, the issue is not about Failover... the RUTx11 is using 4G traffic/data when not failed over.  Tshoot file ... https://community.teltonika-networks.com/?qa=blob&qa_blobid=17375583763514820083

Should it not simply 'register' on 4G and stay Disconnected until a failover occurs? 

No matter what I set -- IF it registers on 4G it Connects and uses data even (when not in failover!)
-- must be a bug, yes? 

Some testing I did...

"AUTO" also registers on AT&T
Forcing to T-Mobile does register but still Connects and uses data
Both always show as roaming.

Often it connects to 4G for few minutes (and eats some data) then change to Searching and connect to 3G and stay there unless I reboot or change a setting.

Changing settings...

1. Result = 4G, Connected, T-Mobile, Registered (roaming)  **data transfers

  • Manually set APN (no authentication)
  • turned OFF Deny Data Roaming
  • set Service Mode to 4G (band selection = Auto) 

2. Result = 4G, Connected T-Mobile, Registered (roaming)    **data transfers

  • changed :: Service Mode to AUTO
  • rebooted (unplugged power)

3. Result = Disconnected & "Searching", 'State' loops between 3G<->4G constantly, AT&T

  • changed :: turned ON Deny Data Roaming

4. Result = 3G, Disconnected, T-Mobile

  • changed :: set Operators to Manual and selected T-Mobile (same as what it selects when in Auto during Test 1 & 2)

 5. Result = 4G, Disconnected, Operator = N/A, Operator State = Unregistered

  • changed :: turned OFF Deny Data Roaming
  • changed :: Service Mode changed to 4G (LTE) Only

 6. Result = 4G, Disconnected, Operator = N/A, Operator State = Unregistered

  • changed :: turned ON Deny Data Roaming

 7. Result = 3G, Disconnected, T-Mobile, Registered (roaming)

  • changed :: Service mode = Auto

 8. Result = 4G, Connected, T-Mobile, Registered (roaming)    **data transfers

  • changed :: turned OFF Deny Data Roaming
by

Hello, 

First of all the issue, your device is using data when it shouldn't when you are on a Wired network not on Mobile data. 

Here is the result for mine: 

There is a 4.23MB usage I will check this with HQ and see what may be the cause for this one. 

Regards,
Mellow

by
Hello,

Regarding this issue of yours would it be possible to leave the device turned on for around 6-7 hours and get a copy of the TCP Dump file for analysis.  

Looking forward to receiving the said file.

Regards,
Mellow
by

@Mellow

Now it will not connect to 4G if I try to force it to. In AUTO it connects to 3G and does not use data but nothing I do gets 4G to connect, only shows 'searching' with Deny Roaming On or Off, and forcing Service Mode to 4G

this graph shows when it was connecting to 4G and using data, then it changed to only connecting to 3G and not using data...

by
Hello,

Regarding your issue, it is best to do a firmware re-flash via the bootloader menu and check it again. Is this sim card used in roaming or no? Kindly make sure both mobile antennae are connected to the device and you have good signal quality from your Mobile ISP provider.

As mentioned once connected try to to make the device run for 5-6hours and get a copy of the TCP Dump file and share it with me for analysis.

Regards,
Mellow
0 votes
by

I did a complete factory reset on the RUTX11, then flashed the new .07 Firmware

Then I ONLY changed I made was to add firewall rules to pass though needed traffic and Failover enabled... NOTHING else.

Now 4G LTE always show CONNECTED (tried Service Mode in Auto and 4G Only) even when not failed over. And there is traffic flow.

I went to get you a TCP Dump -- setting No Longer Exists! (see screenshot)

From the last screenshot of the Traffic, you can see a CLEAR pattern. Looks like a ping or something constantly going. I suspect it does when 'Connected' and detecting for a working connection? But the problem seems that it should not be Connected when not in Failover. Arg.

by

Hello, 

You need to install the TCPDump package in the Package manager (Services > Package Manager) in order for it to appear in the System > Troubleshoot. 

Regards,
Mellow

by
OK, installed. set the Interface to "mob1s1a1". Will post file here in the morning... 4G is using a lot of data!
by
Hello,

Thank you forwarded the tcpdump file to our HQ for analysis.

Regards,
Mellow
by

More info for you, and new dump files attached.

https://community.teltonika-networks.com/?qa=blob&qa_blobid=15134661125039436015

https://community.teltonika-networks.com/?qa=blob&qa_blobid=16923267446137735547

I changed the ping time from 3 to 5 seconds and now I'm 100% sure the traffic is the ping. You can see on the graphs the distance between the spikes is wider than on the prior screenshot.

When I disable mobile under Failover menu (usage chart attached) no traffic is used, at all... but the mobile SIM stays in the 'Connected' state.

The issue is clearly that Failover is not working properly in this .07 FW or prior one at least. Thus, when NOT in Failover it keeps the mobile SIM 'Connected' when it should be 'Disconnected', and thus the traffic are pings that should happen ONLY when Connected in Failover.

by
Hello,

As of now, I have shared this information with our HQ for analysis.

Thanks

Regards,
Mellow