subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
436 views 8 comments
by anonymous

Dear TELTONIA moderators.

Hi. I need your support to solve the issue in Japan.
When I tried to use the sim card of Softbank however finally the connection failure occured based on below condition.

Model : RUT950V02XXX
Confirmed FW version : legacy RUT9XX_R_00.06.09.2 and latest RUT9_R_00.07.02.4 with modem's FW EG25GGBR07A07M2G.
Symptom : The sim card of Softbank was no communicaiton with Sim1 and Sim2 both on the RUT950 however the sim card of Docomo could worked on both sim slot fine w/o any special magic = Auto APN worked well.
Factory reset : YES tried but not solved.
Note : I tried same solution which found by Taisyo for his issue of RUT240 on this thread.
         My RUT950 seems have same "Module locked" issue but now my RUT950's lock was free (Confirmed sim inserted condition on system) thanks to Taisyo.
         However finally the commucnaition error could not solve so far.

The syslog of Docomo and Softbank both cases are as enclosure.
Would someone verify them then give me the advice to fix this issue immediately.

Thank you very much for your understanding and cooperation.

1 Answer

0 votes
by anonymous


It is most likely that this is happening due to a firmware issue on the Quectel modem because it was a known issue for them and it has been resolved in the newer FW version of the modem.

This is the instruction for modem FW update (NOTE: at least 7.2 version is needed for this to work)


With 7.2 and above firmware versions you can use the modem updater tool:

There are instructions (CLI commands):

  1. opkg update
  2. opkg install modem_updater
  3. opkg install sshfs
  4. modem_updater -g (will parse device modems  with ID numbers and available firmware versions)
  5. modem_updater -i <ID> -v <VERSION>  Modify this based on the output of the last command (use the second modem ID and firmware version name you would like to install) 
Make sure that your router will have an internet connection through other modem or Wired/Wireless WAN (not through the modem you are updating).

by anonymous

Thank you so much for your prompt reply PauliusRug.

I wanna clear below points before I tired to do modem FW updating via CLI.

  • My RUT950's latest modem's FW version is EG25GGBR07A07M2G which updated via RUT9_R_00.07.02.4.
    However you meant this modem FW version is useless for this issue?
  • If so, when the TELTONIKA will officially implement the latest modem's FW to RUT's one?

Thank you in advance.

by anonymous
The latest modem FW version is: EG25GGBR07A08M2G

Regarding the inclusion of the newest modem FW into the standard device FW is impossible due to the size of the modem firmware and that would be impractical to include it together with the device firmware.

Currently, after upgrading the router FW, the modem FW always stays the same.
by anonymous

Hello now I'm tring to solve this issue with the advice.
However some problem occured while I tried to update the modem's FW to latest.
Would somebody give the advice again.

  • opkg update process
    Occured one download fail as below. Does this influence to update process?
    Signature check passed.
    Collected errors:*opkg download: Failed to download ses/21.02.0/packages/mips_24kc/vuci/Packages.gz, wget returned 8. root@Teltonika-RUT950:~#

  • modem_updater -i process
    Occured the error as below. How should I solve the timeout and directory empty both?
    [000.049]: qusb_noblock_open port_name /dev/ttyUSB0
    [005.284]: src/firehose/qfirehose.c detect and judge_module_version 156 fail
    [006.287]: poll_wait events=POLLIN msec=1000 timeout
    [006.287]: switch to Emergency download mode'
    [009.292]: poll wait events=POLLIN msec=3000 timeout
    [ERROR] firmware directory is empty. Mount failed? Exiting...

Thank you for your cooperation. 

by anonymous

opkg update process

No, it does not influence anything, it's just that vuci packages are no longer available on the openwrt repository but we still try to scan for them, might get removed in the future to avoid confusion.

Regarding the second point, I will conctact RnD to see what could be happening as to why there are no files for this particular FW is missing from the server

by anonymous

Thanks for your update PauliusRug.
Okay I understood that I have to solve the issue of modem_updater -i process only.
Would you try to get any technical advice from your RnD team today. I will try to check other point just in case.

by anonymous

Hello again. here is an update from my side.
Fortunately I could completed the modem FW updating process with below points.

  • Turned off WAN and WAN6 via network interface menu
  • Utilize the WiFi client mode to have the connection with internet but tethering with Docomo mobile network (e.g. via your iPhone) didn't work due to SSH conneciton blocking by Docomo however tethering with Softbank mobile netwrok worked correctly
  • Finally the process finished as this log file * Shared this for somebody's reference
    2022.08.09 Modem fw update log - success.txt

Then my RUT950 actually has the latest modem's FW "EG25GGBR07A08M2G" also I cofirmed this on the GUI by my eyes.
But the problem of Softbank's simcard is still continue.
Would you verify the log files as below what was going on the RUT950 then give next advice for me. 

  1. 2022.08.09 softbank connection fail 1.txt
  2. 2022.08.09 softbank connection fail 2.txt

Thank you for your cooperation.

by anonymous

After talking to RnD they said that yeah, this most likely happened to the port 22 being blocked by the local network, we will update that message in the future releases so it would more clearly state what happened and why the folder is empty.

Regarding the connectivity issue, that seem not great, woul you be able to send the full troubleshoot file and I would be able check out every setting on the device the other log files that are available?
by anonymous
Thanks for your feedback. Got it now I shared the full troubleshoot file with you via private message.
Please check them for your reference?