subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
555 views 3 comments
by anonymous
My RUTX12 will always disconnect from Mobile Internet. A established connection will force disconnect and the interface is going to "offline" after a few minutes. Then the connection will come up again and disconnect after a few minutes again.

I've tried several different firmware versions and SIM-Cards.

My Provider is T-Mobile in Germany. This happens within germany and in roaming mode too.

Any suggestions?

4 Answers

0 votes
by anonymous


I would like you to attach a troubleshoot file to your question. Please, replicate the issue, then access router's WebUI, go to System -> Administration > Troubleshoot section and download troubleshoot file from there.

Files are private and visible only to Teltonika Moderators.

Best regards,

by anonymous
thanks for the fast answer.
How can I upload the troubleshoot-file?

Best regards
0 votes
by anonymous


I hope this was the correct way uploading wink

by anonymous

It appears that you have a faulty unit. One of the modems is not visible by the processor at all, the remaining one keeps constantly disconnecting. Below are a couple of things to try, otherwise, return the device for warranty repair.

Update the router's firmware to the latest, preferably with Keep settings option disabled.

Next, the router has a really old modem firmware version, which I advise to update too. For this you will need an alternative internet source than the mobile. Since the same modem is used in RUTX09, you can find instructions for the procedure in one of the previous threads: 

If a secondary WAN is unavailable, you can check a different way to update in the below link: 

Best regards,

0 votes
by anonymous

The firmware update to 7.2.6 worked fine.

After this I tried to made an update for the modem as explained within the other case.

I first tried to made this update with an alternate WAN-Connection (iPhone as hotspot).
This results with the following:

"opkg update" returns:

Collected errors:
 * opkg_download: Failed to download, wget returned 8.

"modem_updater -g" returns:

Available versions:
umount: can't unmount /tmp/fwlist/: Invalid argument

The list of available versions remains empty.

The second try was to made the update offline.
I copied all the files of the from your website
unzipped all files and copied them via scp to the RUTX' /tmp/ directory

"modem_updater -i 3-1 -p /tmp/Update/" worked after that.

I'll try and check out the mobile connections and will report to you.
so please stand by wink

Thanks for your support.


0 votes
by anonymous
unfortunately the firmware updates for router and modem does not fix the problem.
The connection is established and crashes within 5 minutes, less or more.

So, should I return for warranty? Should I then return to my dealer or direct to Teltonica?

Thanks in advance

by anonymous
Return the router to your reseller.