FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
251 views 1 comments
by anonymous
Hello,

I am trying to get data from a Seko 800 via modbus RTU. I did install the modbus serial master, and followed the config instructions on this link:
https://www.fogwing.io/blog/connect-teltonika-trb145-to-fogwing-platform/
and
https://community.teltonika-networks.com/47830/modbus-rtu-master-and-mqtt?show=47830#q47830

However all I get is the follwoing error when trying to test.
"No response from slave device, check wiring and configuration"

Link to Kontorl 800 manual - https://cdn.seko.com/s/10f63247-eef7-4b02-bce1-2e00b2851cfc/Measurement++Analysis.pdf
I have attached screenshots of the configs. Any assistance will be greatly appreciated.
by anonymous
Hello All,

I was able to get the devices to talk, so just wanted to note it for anyone having any similar struggles. The wiring was as per the Fogwing link.

The trick was in config, what worked in the end was as follows:

Baud rate:19200, Data Bit: 8, Parity: Even, Stop bits: 1, Flow control: None, Full Duplex: Off

2 Answers

0 votes
by anonymous

Hi,

Please the rs485 wiring connection, if they are properly configured. It should be like this:
https://wiki.teltonika-networks.com/view/RUT955_RS485#RS485_connector_pinout
Please share the Modbus addressing scheme via PM and also try to change the function to "Read holding register(3)" on Modbus serial master and try again.

Regards,
Raman
 

0 votes
by anonymous
  • I remember seko was a blower manufacture like DEREIKE