FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

12691 questions

15070 answers

24150 comments

47148 members

0 votes
251 views 23 comments
by
When wired LAN connection from the PC everythig works fine. But when i activate openVPN in trb140 software, it stops conneting to lan devices connected to the router. Via openVPN tunnel i can only ping or acces the router, not the lan connected divice.

2 Answers

0 votes
by
Hello,

Is your TRB device configured as a server or a client?

Could you provide a topology of your network and details of your configuration?

Best regards,
by
it is configurated as a server. there is a trb router, and connected via Lan Schneider M251 controller. I need acces to the controller via OpenVpn tunnel.

There is a static ip on the router from SIM card provider.

OpenVpn tunnel is configured, and works fine, but i can not acces lan connected device, i can only acces the router.
by

I suggest to check the following link, specifically section Reaching a device's LAN networkhttps://wiki.teltonika-networks.com/view/OpenVPN_configuration_examples#Reaching_a_device.27s_LAN_network 

by
this is first thing i did before asking for help. I can give you remote acces via http to the router on PM. if it helps.
by

Could you attach a troubleshoot file to your question. Please, replicate the issue, then access router's WebUI, go to System -> Administration > Troubleshoot section and download troubleshoot file from there.

Files are private and visible only to Teltonika Moderators.

by
file added to main question
by

First, you need to change Virtual network IP address. It has to be within a private IP range but not the same as the current LAN network, for example 10.0.0.0.

Either client or server device needs to be on a different subnet. If your server's LAN is 192.168.1.1, change client's subnet to, for example,192.168.10.1.

If the server's IP is 192.168.1.0, the push option should be route 192.168.1.0 255.255.255.0

I have noticed that there are a lot of blocked IP addresses, who have tried to connect to your device remotely on port 22.

by
nothing helped. new troubleshoot file added for you to see
by
now i don't see device in ARPsection status Routes, ip and mac adress was shown before, now nothing.
by

Since your server's LAN is now 192.168.2.1, push option should be route 192.168.2.0 255.255.255.0.

by
done, still no acces to lan via OpenVPN
by
i can't eaven ping the router from lan connected m251 controller software, when openVPN is on, when its off the ping returns.
0 votes
by
tried setting everything once again, still not working
by
Please delete client configuration instance on TRB device.

Could you also show .ovpn client configuration file from your PC?
by

client config delated. this is my client.ovpn file

by
is it ok? or maybe there is my problem?
by
Please help. Still no clue. i need this working
by

Got it. Everything works fine now. Problem was port forwording. I did it "upside down" this is why it dident worked.

It should be forworded from openvpn to Lan. My setting was from Lan to OpenVpn.