8317 questions

9780 answers

15562 comments

13905 members

0 votes
261 views 1 comments
by

RUT955 CONNECTION IS ESTABLISHED, INTERNET ACCESS IS JUST, 5 MINUTES

2021-06-17

Few months ago I bought the RUT955. The performance for about 4 weeks was extremely reliable. Quick, not fault at all.

It use to remain me my first cable connection. Highs downloads and highs uploads. Low Latency, etc.

I had been used at home, in the country side. With a computer running Ubuntu 20.04. With several KVM Virtual Machines in NAT mode and some one in nested virtualization.

At least 3 of the Virtual machines had been using the Internet at the same time for few moments, included one with Windows 10. Some one could had been used for watching some Videos, another one for Watching TV, some other one downloading some files with Transmission, some other one browsing the net with Firefox.

Not a problem at all. It was very difficult to believe how good all the system was running.

Since I am planning to install the system in a Truck Motor-van. I started to active the GPS. To set up several Wireless Access Points.

Sometimes, with the purpose of testing the capabilities of the router and the ISP, I was using the 3 SIM cards connected to the Internet at the same time. One at the router, one at the Mobile Phone and one at the Android Tablet. Every things seamed to work fine. Unbelievable.

I have 3 SIM cards with the same provider and the same telephone number (movistar with a mobile unlimited data plan in Spain). One of the Sim cards is used at the RUT955.

My configuration apart from the factory one was simple. Since I use it with a SIM card, I setup my Mobil connection to be my Wan connection. No Wan Faileover, neither Load Balancing. Since I do not have a Wired WAN neither a second SIM card inserted with other different provider.

At the WAN advanced settings I just changed the use of DNS for a custom DNS. Those where 1.1.1.1 and a second one of 1.0.0.1 from Cloudfare.

The Mobile configuration also was simple. QMI, NAT Mode, Auto APN and 3G+4G.

Network frequency Bands was set just one in manual mode, this was LTE B20. Al thought I checked all of them, one by one and I found that I had 5 of them with good performance of up to 64Mbps Download, 22.50 Upload, Latency of 47 ms and jitter of 2.5. Those data was the best performance, but it would not change very much.

The other Frequency Bands where WCDMA 2100, WCDMA 900 GSM 1800 and GSM 900. But since with the LTE B20 every things worked well, I did not select any one else.

As for firewall and others, I did not other thing than opening few ports.

I did test the SMS capabilities for Mobile Data Limit. It was performing fine, sending SMS at the right time. Since I don need it I Unable the choice.

At the LAN Side I started to set some Static leases for my printers, scanner, laptop and PC. Fine, no trouble at all.

RMS is disabled.

I also used an Express VPN connection. Although I set up one in the OpenVPN menu in RUT955. I used it only once due that the speed of the Open VPN protocol was much lower than using the "Lightway Protocol" in the Firefox ExpressVPN extension.

Anyway, it had been working every thing fine until a week ago.

Firstly, when I woke up I found that there was not connection “to the internet” in mine main PC, therefore neither I had connection in VMs.

During 5 days I had been trying to trouble shoot the problem. I started uninstalling the Express VPN. Since the first thing I realized it was that while I use the ExpressVPN extension in Firefox every thing works fine, but as soon as I cut the VPN connection I was unable to connect normally to Internet.

The second thing I did it was to check the FireWall, but I did not touch the settings except opening some ports. So, nothing to fix.

Finally, after many checking. I did reboot the RUT955 to factory settings. Today I installed a new firmware that was available (RUT9XX_R_00.06.08.2). I set up DNSs to factory defaults, then I setup the Cloudfare ones, then I setup the google ones.

I had been reading all the article in related to this problem. It is the RUT955 connects to the mobile APN, but after around 5 minutes it start to loose connection to the internet. After 10 minutes it is impossible to open any web page. And after the first 3 to 4 minutes my speedtest from Ookla start to give me messages like:

2021-06-17 22:00:29.584] [error] Trying to get interface information on non-initialized socket.

[2021-06-17 22:00:35.099] [error] Configuration - Couldn't resolve host name (HostNotFoundException)

[2021-06-17 22:00:35.099] [error] Configuration - Cannot retrieve configuration document (0)

[2021-06-17 22:00:35.099] [error] ConfigurationError - Could not retrieve or read configuration (Configuration)

[2021-06-17 22:00:35.100] [error] ConfigurationError - Could not retrieve or read configuration (Configuration)

[error] Configuration - Could not retrieve or read configuration (ConfigurationError)

So, As I said, I had been around 5 days already trying to see what is the problem to solve it.

I had been reading those articles from this forum, all of them related, an some one identical to the one I have. Some one already since 2019. Those are:

https://community.teltonika-networks.com/29347/rut230-no-connection

https://community.teltonika-networks.com/22512/rut950-sim-ok-but-no-internet-acces

https://community.teltonika-networks.com/9655/rut240-with-sim-card-still-internet-access-what-should-check

https://community.teltonika-networks.com/20109/rut950-connected-to-mobile-network-but-access-the-internet

https://community.teltonika-networks.com/16144/rut240-connected-but-no-net

https://community.teltonika-networks.com/15600/error-failed-to-resolve-hostname

https://community.teltonika-networks.com/6312/failure-error-failed-to-resolve-hostname

https://community.teltonika-networks.com/24602/rut230-failed-to-resolve-hostname

It does not matter if I revert to factory settings. If I leave alone or change the DNS. If I set mobile as first WAN. If I change SIM cards, if I ping. Etc, etc, etc.

The only thing it appears to happen is as follow:

I go to Mobile Information, if I reboot the modem is OK, but it is faster to push the (Re)register Bottom. It takes around 44 seconds. Then every things works fine. Web pages without cache file loads in around one second, as much as 2 seconds. I can click in any of my hundreds bookmarks an they load with the speed of a thunder. Fine no problem.

I test the speed and it is ok, as follows:

Speedtest

Speedtest by Ookla

Server: MismeNet Telecomunicaciones - Churriana de la Vega (id = 6425)

ISP: Telefonica de Espana Static IP

Latency: 47.86 ms (4.22 ms jitter)

Download: 57.84 Mbps (data used: 76.5 MB)

Upload: 22.48 Mbps (data used: 24.0 MB)

Packet Loss: 0.0%

Result URL: https://www.speedtest.net/result/c/c1b5e7f0-96c8-42f4-a6a2-2badf6b36dd6

After 4 minutes it is impossible to do any more speed test. After 5 minutes web pages start to take time to load. After 10 minutes you can not see any web page.

The only choice and the fastest is to go to Mobile Information at the RUT955 an press the (re)register tab. But you can do it only after roughly 7 to 10 minutes has passed. Otherwise nothing changes.

To wrap up. My modem is always connected to the APN. Normal use of Internet is only for around 4 to 5 minutes. Then is a frustration. The only way is to (RE)REGISTER the RUT955, and you are all set up for another 5 minutes of Internet.

I thought to recommend this Router to some friends, obviously now I am rethinking even if to buy anything else from TELTONIKA.

Any way to fixed the problem will be welcome. I can send the Troubleshoot file. I can answer some more question, but really, I am very , very tired. I am very frustrated with this device. To the point that I will try to apply for the warranty if I do not find a solution to the problem.

NB:

One more update, As with the VPN, it happens the same with Amazon Prime Video. Yesterday I could see a Video in Amazon. It takes about 2 hours, I could see it without any interruption in the connection. At the same time that I was watching the video, I could not browse the net at all. Not a single page.


 

It looks like that once you get a Socket connection within a window of 5 minutes, it keep it correctly. After that no more Socket connection.


 

It is a RUT955T033B0

FW: RUT9XX_R_00.06.08.2

p { margin-bottom: 0.25cm; line-height: 115%; background: transparent }a:link { color: #000080; so-language: zxx; text-decoration: underline }

2 Answers

0 votes
by

Hi,

Could you please roll back the firmware back to RUT9XX_R_00.06.07.7 and tell me if the issue with mobile disconnections persists, it seems that you're not the only one having this issue with that exact firmware, so just roll back and I would be happy if you could tell me if everything works again.

Other than that, I appreciate your feedback and I'm happy that our RUT955 could serve you that long without any issues.

EB.

by

Now, first, thank you very much for your quick replay EB.

The first thing I did it was to revert to the FW “ RUT9XX_R_00.06.07.7”. It was fine for minutes. Then again the same problem as before.

Second, I started to change settings at WAN Page to set the main WAN to Mobile, not Failover, neither Load Balancing.

Second thing was edit WAN configuration. I set custom DNSs to 1.1.1.1. and 1.0.0.1

I left alone UDP Broadcast Relay alone, as a default it is not enable. I am not a technician, but I wonder if it should be set to Enable.

For a while (10 minutes) every things seemed correctly. Until it started to behave as before, first, the web pages takes long, long to load (45 seconds, 1 minute, etc). Then it does not load anything.

I went back to do the old trick, it is to (re)register at the Mobile Data Connection state. I did once, and my surprise was that now, after hitting the tab, the data connection states shows DISCONNECTED. It never happened before. Even I pressed the (re)register bottom 10ths of times.

Now I press the Restart connection Tab. Nothing appends, it keeps Disconnected.

Next I Reboot the modem from the tab at the same page, let see whats happens.

Eureka, it says connected.

I do a Speedtest check, good, those are the results:

speedtest


 

Speedtest by Ookla


 

Server: MismeNet Telecomunicaciones - Churriana de la Vega (id = 6425)

ISP: Telefonica de Espana

Latency: 39.90 ms (2.53 ms jitter)

Download: 58.00 Mbps (data used: 69.9 MB)

Upload: 22.43 Mbps (data used: 20.4 MB)

Packet Loss: 0.0%

Result URL: https://www.speedtest.net/result/c/b4cf1e95-c1fb-4f43-9c31-a7a3e7c2c78a


 


 

3 minute later I do the same speedtest. Good again.


 

I start to surf the web, pages not recorded in cache memory. Wonderfully, again they load with the speed of a thunder. Pages in Japan, USA, etc. Even the CNN that is “full of crap” it loads in 2 seconds.

We are already 7 minutes 30 seconds since rebooting the modem.

Upps, “Teltonika, we have a problem” Beethoven at YouTube, seams to have a minute delay.

Does not want to play. It says:

Hmm. We’re having trouble finding that site.

We can’t connect to the server at consent.google.com.

If that address is correct, here are three other things you can try:

Try again later.

Check your network connection.

If you are connected but behind a firewall, check that Firefox has permission to access the Web.

10 minutes later than I did the reboot, the speedtest shows:

speedtest results:

[2021-06-18 13:52:48.856] [error] Trying to get interface information on non-initialized socket.

[2021-06-18 13:52:54.374] [error] Configuration - Couldn't resolve host name (HostNotFoundException)

[2021-06-18 13:52:54.374] [error] Configuration - Cannot retrieve configuration document (0)

[2021-06-18 13:52:54.374] [error] ConfigurationError - Could not retrieve or read configuration (Configuration)

[2021-06-18 13:52:54.374] [error] ConfigurationError - Could not retrieve or read configuration (Configuration)

[error] Configuration - Could not retrieve or read configuration (ConfigurationError)

In a very shy way Beethoven try to load the page. Not response. It is already 5 minutes after the try.

Other web pages, does not response at all.

Lets do the (re)register trick, 18 minutes after the reboot. Data connection state says it is connected.

Again, an this is new. After (re) registering the modem it says DISCONNECTED.

Lets hit the Restart connection tab. Nothing, no response. Twice, no response.

Lets do the reboot modem tab.

Again EUREKA. The data connection says it is connected, the speedtest is working, and without changing tabs, I start to listen “Für Elise by Beethoven” that I tried to load before. (It is mine reword, I deserve that pleasure.)

Again Timer up. Speedtest working. Web pages working.

3 minutes after the reboot, web not working. Mobile connection state, connected. Browser does not work at all. Ubuntu network info is in “?” state. I start Nextcloud Synchronizing . It gives me this message: “Server replied with an error while reading directory”: Host not found.

While I do this, Beethoven at YouTube, still delighting my senses. Is still loading the data as it plays. So, there is a before connection that still works. No new connections ones.

Well, this is enough.

To conclude, even I revert to the “ RUT9XX_R_00.06.07.7” FW. It does not solve the problem, moreover, now when I hit the tab of (re) registering, it gives me a disconnected message. Before it use to be connected but not response. It is weird.

Also I have to point out that the problems started with this same FW “ RUT9XX_R_00.06.07.7”. With out doing nothing at the RUT955 settings. I just had the settings , connections and system, all working correctly for few weeks, until suddenly, the connection fall over.

I changed to the next FW “FW: RUT9XX_R_00.06.08.2” to see if the problems disappeared, not for other reason.

To finish. The problem keeps as before, with the one exception regarding the “Disconnected” message.

But still. I can realize that once VPN connection started, it did not fall over. Once the Amazon Prime video started, it did not fail over, and now, I have the pleasure to know that Beethoven connection at YouTube, once it started, it did not fail over. (web pages as for this exactly moment, they don not load. Neither synchronizing Nextcloud).

Really, I wait for your response because I know that it has to have a solution. And as long as I can cooperate to solve it, I will. But I am not a technician.

Sorry for the “no sense” info, but I have to keep the humor sense after so frustrating times.

NB:

Last update, before I reboot the modem to send you this message I went to edit the DNSs and left them as the default ones, that is “Use DNS servers advertised by peer”.

After I pressed the save the settings, I could load few web pages for a couple of minutes, very slowly (remember, it did not load any page in the last 30 minutes). But the speedtest dose not response, neither the Nextcloud synchronizing.

Also it is interesting to know that my proton mail account web tab that it was started time ago, an has the permit in Firefox to update me for new incoming mails, it is sending me updates continuously about my new mails. Further more, I wen to my proton mail tab and it is possible to load the new messages

(they are not in this PC, they are at their server) (Again, that connection that was done before, since I started the PC, hours ago, is keep alive for some reason I really do not know)

An right now after 10 minutes. Again no web page loads. Just the mail and YouTube video is active. As from the beginning.

It looks like once I saved, I pressed the save tab at the DNSs setting it “restarted”, “refreshed” the connection to the internet for new web pages to load. Just for 3 to 4 minutes.

p { margin-bottom: 0.25cm; line-height: 115%; background: transparent }a:link { color: #000080; so-language: zxx; text-decoration: underline }

0 votes
by

UPDATE


 

2021/06/20

RUT955 INTERNET ACCESS PROBLEM, SOLVED

So, what was the problem? As always once you solved, it was very easy solution.

My ISP recently, added a new APN interface parameters. And now I can see 2 APNs from the same provider that cohabit” in the same APN Interface list from the RUT955.

The only thing I had to do was, at the Network>Mobile>SIM Mobile configuration. To unchecked the “Auto APN” field. After doing that, a new APN List field appears. Inside of this list you choose the APN name that (in my case) I got from my ISP. And them you save the work.

Then every thing became as before, not a single connection cut, fast, very fast internet browsing (as has to be), not “wandering” while seeing the pages loading for 5, 10. 20 seconds,not a single :

Trying to get interface information on non-initialized socket”, “Configuration - Couldn't resolve host name”, “ Cannot retrieve configuration document”, “ConfigurationError - Could not retrieve or read configuration”, Etc,etc,etc. Annoying message.

Light came on.

I realize that once I did pressed the “save” tab, at the MTU field, instead appearing 1500 as before, it was filled with an “admin” word. And the field surrounded in red color.

I just lived it alone. I imaged that from that moment the MTU is managed by the APN Config. Files. It is non of my business if they want control the MTU, as long as I have a decent connection. That which I have now.

So simple , so easy.

Before I got to that point, I had a week in hell. I was at the APN settings. I changed parameters. I was in Firewall Settings, the same, I changed parameters. I disconnected different services. I Checked System Status, I checked connections.

For many of the parameter, I did normal reboots, then factory reboots, (Tenths of times) Downgrade FW, Upgrade FW.

I checked Firefox settings, PC network settings. I interchanged SIM cards. ETC, etc,etc…

I was desperate. I was thinking that the problem was either from my ISP or RUT955 Software. Since my other SIM cards “seamed” to work fine in the tablet and the phone.

I was decided to get info to “completely do a Clean reinstall” of the RUT955 FW through the CLI.

Suddenly, it came to my mind to do a last check. It was to set my phone as a Wireless Access Point and to set this connection as Wireless WAN Failover at the RUT955.

What was my surprise to realize that the phone Internet connection was having the same problems as the RUT955. It was not working as good as it seamed to work when you browse the Net at the Phone or Tablet.

I just went to the IPS provider Web Page and I made them to call me Back for technical Assistance.

10 minutes later they call me back. I explained the problem.

For the Phone and Tablet (android) I had to set up parameters manually that they gavi me.

For the RUT955 I just had to select the Right, New one APN that appeared in the list (I don know when, may be a couple of weeks ago). And it was all, so easy.

Now, some one could rightly think, Why did not reach the ISP from the first moment it was the trouble?. Well, in my case, in the country I leave right now, the last 20 calls I did to the ISP were worthless, infuriating, irritating, deceiving. And let you in a very frustrating sense state.

When you don get a boot telling you just, any thing, you get a a person that talks like a boot.

When they do not just “ups, telephone connection suddenly got cut in the right moment you were telling something that the operator did not have answer”. They just try to invent any answer because the think the person at the other side of the line is, more or less, an ignorant (to say it in politely way).

Or they just try to sell you something. Or they are lying you in the info they give you. Or they say you that the price of something is X and them, later, charge you X + X. Or they just keep you waiting for very long times. Etc.

Well, in the above case, the very last thing you want to do, is to call to your ISP. Instead you try to fixed the problem by yourself, in forums, whatever it takes. But not to touch the Ogre.

But not every things was a waste of time, not at all.

I learned few positive things. One of them was to see at the Status>Events Log Tab, a few more Tabs, where you can easy apply filters and search for different events.

As an example, you can select the Network Event>Mobile Data Filter. Where it will show you just connections, disconnections and leased IPs in an orderly way.

From that, I realize that as long as my connection was working fine, my ISP use to renew me the IP Address, daily, almost at the same time every day.

When I started to have connection problems, the ISP has had giving me up to 30 different IP leases per day.

Of course you can see the same and more info at the System>Administration>Troubleshoot Tab. But those are logs, Test files, with more in deep Info in a readable way.

The other info you can see it at the Events Tab, it is like if you where working in an LibreOffice Calc File. You can pivot the info with different filters in a much easier and quicker way.

Another thing I realized, an really made me very worry for a while, it was to know that, even I did several Factory Resets, FW Upgrade, Downgrade, and again Upgrade again. ALL the RUT955 Logs since I both the Router, still they were available. Event more, the SIM pin is also no deleted.

Well, good or bad, I do not know. Of course, to still be able to see all the old and new Logs, it is very practical Info.

On the other hand, it made me to think that, in the same way it keeps some old info after Factory Reboots, why not it could keep some other files that could lead to “File Corruption”??? Now, what is the meaning of “Factory Reset Defaults”??

And one more thing. Many times that I had to troubleshoot networking or other Electronics devices. Most of the times the problem relays in a Physical fault, like it can be a RG45 bad connection cable. A broken solder plug connection, etc.

Here there where no cables. Just a “wirelesses Connection”. And it was it. The very first hop I should had check more carefully, instead of trying to troubleshoot more “far away” subjects.

Any way, all those where just stories of a retarded Computer User. If any info I gave here was of a good use for any one. Congratulations.

The device (RUT955, Serial 1106341385 with FW RUT9XX_R_00.06.08.2_WEBUI.bin) as for this moment (24 Hours after solving the incident), it is working flawlessness as a Mobil Modem with Active SIM and several LAN connections, Active GPS, RMS, SMS Messaging Alerts, etc.


 


 


 

p { margin-bottom: 0.25cm; line-height: 115%; background: transparent }